Permalink
Browse files

Updated version deps for rb-fsevent & rb-inotify

  • Loading branch information...
1 parent 5808a3c commit deec4135a9a36c775a6c460cd13214d089bb36f1 @thibaudgg thibaudgg committed Jun 4, 2011
Showing with 9 additions and 13 deletions.
  1. +2 −2 Gemfile
  2. +4 −6 lib/guard/listeners/darwin.rb
  3. +3 −5 lib/guard/listeners/linux.rb
View
@@ -5,11 +5,11 @@ gemspec
require 'rbconfig'
if Config::CONFIG['target_os'] =~ /darwin/i
- gem 'rb-fsevent', '>= 0.3.9', :require => false
+ gem 'rb-fsevent', '>= 0.4.0', :require => false
gem 'growl', '~> 1.0.3', :require => false
end
if Config::CONFIG['target_os'] =~ /linux/i
- gem 'rb-inotify', '>= 0.5.1', :require => false
+ gem 'rb-inotify', '>= 0.8.5', :require => false
gem 'libnotify', '~> 0.1.3', :require => false
end
if Config::CONFIG['target_os'] =~ /mswin|mingw/i
@@ -23,19 +23,17 @@ def stop
def self.usable?
require 'rb-fsevent'
- if !defined?(FSEvent::VERSION) || Gem::Version.new(FSEvent::VERSION) < Gem::Version.new('0.3.9')
- UI.info "Please update rb-fsevent (>= 0.3.9)"
- false
- else
- true
+ if !defined?(FSEvent::VERSION) || Gem::Version.new(FSEvent::VERSION) < Gem::Version.new('0.4.0')
+ UI.info "Please update rb-fsevent (>= 0.4.0)"
end
+ true
rescue LoadError
UI.info "Please install rb-fsevent gem for Mac OSX FSEvents support"
false
end
private
-
+
def watch(directory)
worker.watch directory do |modified_dirs|
files = modified_files(modified_dirs)
@@ -24,12 +24,10 @@ def stop
def self.usable?
require 'rb-inotify'
- if !defined?(INotify::VERSION) || Gem::Version.new(INotify::VERSION.join('.')) < Gem::Version.new('0.5.1')
- UI.info "Please update rb-inotify (>= 0.5.1)"
- false
- else
- true
+ if !defined?(INotify::VERSION) || Gem::Version.new(INotify::VERSION.join('.')) < Gem::Version.new('0.8.5')
+ UI.info "Please update rb-inotify (>= 0.8.5)"
end
+ true
rescue LoadError
UI.info "Please install rb-inotify gem for Linux inotify support"
false

0 comments on commit deec413

Please sign in to comment.