Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 41 lines (32 sloc) 1.42 kb
6759403 @igrigorik oh hai!
igrigorik authored
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "vimgolf/version"
4
5 Gem::Specification.new do |s|
6 s.name = "vimgolf"
7 s.version = Vimgolf::VERSION
8 s.platform = Gem::Platform::RUBY
f047951 @igrigorik thor for cli
igrigorik authored
9 s.authors = ["Ilya Grigorik"]
10 s.email = ["ilya@igvita.com"]
11 s.homepage = "http://github.com/igrigorik/vimgolf"
d6e63b3 @igrigorik rescue cli
igrigorik authored
12 s.summary = "CLI client for vimgolf.com"
f047951 @igrigorik thor for cli
igrigorik authored
13 s.description = s.summary
6759403 @igrigorik oh hai!
igrigorik authored
14
15 s.rubyforge_project = "vimgolf"
bc909cf @igrigorik require latest thor
igrigorik authored
16 s.add_dependency "thor", ">= 0.14.6"
9f97188 @igrigorik download challenge
igrigorik authored
17 s.add_dependency "json"
a0d6325 @jmazzi Highline is required in lib/vimgolf/ui.rb on line 48
jmazzi authored
18 s.add_dependency "highline"
4d3ff1c @igrigorik grrr, rspec + autotest is pain
igrigorik authored
19
20 s.add_development_dependency "rspec"
6759403 @igrigorik oh hai!
igrigorik authored
21
22 s.files = `git ls-files`.split("\n")
23 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
24 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
25 s.require_paths = ["lib"]
ee69cd6 @igrigorik add install banner
igrigorik authored
26
27 s.post_install_message = %{
28 ------------------------------------------------------------------------------
5e6d9d6 @igrigorik bump version to 0.2.0 - now with proper scoring!
igrigorik authored
29 Thank you for installing vimgolf-#{Vimgolf::VERSION}.
30
31 0.1.3: custom vimgolf .vimrc file to help level the playing field
32 0.2.0: proxy support, custom diffs + proper vimscript parser/scoring
8a64804 @igrigorik bump to 0.3.0
igrigorik authored
33 0.3.0: improve windows support, switch to YAML to remove c-ext dependency
34
35 *NOTE*: please re-run "vimgolf setup" prior to playing!
ee69cd6 @igrigorik add install banner
igrigorik authored
36
37 For more information, rules & updates: http://vimgolf.com/about
38 ------------------------------------------------------------------------------
39 }
a0d6325 @jmazzi Highline is required in lib/vimgolf/ui.rb on line 48
jmazzi authored
40 end
Something went wrong with that request. Please try again.