Permalink
Browse files

test suite: don't use Rails 3, avoid deprecation warning with 2.3.9

  • Loading branch information...
1 parent d2fb846 commit 060e61da9a92eab2891f61882b3f76dae40b70ea @mislav committed Sep 9, 2010
Showing with 4 additions and 3 deletions.
  1. +2 −2 test/boot.rb
  2. +2 −1 test/lib/activerecord_test_connector.rb
View
@@ -15,7 +15,7 @@
if version
gem 'rails', version
else
- gem 'actionpack'
- gem 'activerecord'
+ gem 'actionpack', '< 3.0.0.a'
+ gem 'activerecord', '< 3.0.0.a'
end
end
@@ -28,7 +28,8 @@ def self.setup
def self.add_load_path(path)
dep = defined?(ActiveSupport::Dependencies) ? ActiveSupport::Dependencies : ::Dependencies
- dep.load_paths.unshift path
+ autoload_paths = dep.respond_to?(:autoload_paths) ? dep.autoload_paths : dep.load_paths
+ autoload_paths.unshift path
end
def self.setup_connection

0 comments on commit 060e61d

Please sign in to comment.