Permalink
Browse files

use postgres instead of "pg" to work on ruby 1.8.6

  • Loading branch information...
1 parent cad20bd commit 87eef6fd048b0928995061635b52f79a549131b9 @mislav committed Jul 28, 2011
View
@@ -9,4 +9,4 @@ gem 'rake', '~> 0.8.7'
gem 'mocha'
gem 'sqlite3'
gem 'mysql', :group => :mysql
-gem 'pg', :group => :pg
+gem 'postgres', :group => :pg
View
@@ -9,7 +9,7 @@ GEM
activesupport (2.3.12)
mocha (0.9.12)
mysql (2.8.1)
- pg (0.11.0)
+ postgres (0.7.9.2008.01.28)
rack (1.1.2)
rake (0.8.7)
sqlite3 (1.3.4)
@@ -22,6 +22,6 @@ DEPENDENCIES
activerecord (~> 2.3.6)
mocha
mysql
- pg
+ postgres
rake (~> 0.8.7)
sqlite3
@@ -6,4 +6,4 @@ gem 'rake', '~> 0.8.7'
gem 'mocha'
gem 'sqlite3'
gem 'mysql', :group => :mysql
-gem 'pg', :group => :pg
+gem 'postgres', :group => :pg
@@ -13,7 +13,7 @@ GEM
activesupport (1.4.4)
mocha (0.9.12)
mysql (2.8.1)
- pg (0.11.0)
+ postgres (0.7.9.2008.01.28)
rails (1.2.6)
actionmailer (= 1.3.6)
actionpack (= 1.13.6)
@@ -30,7 +30,7 @@ PLATFORMS
DEPENDENCIES
mocha
mysql
- pg
+ postgres
rails (~> 1.2.6)
rake (~> 0.8.7)
sqlite3
@@ -9,4 +9,4 @@ gem 'rake', '~> 0.8.7'
gem 'mocha'
gem 'sqlite3'
gem 'mysql', :group => :mysql
-gem 'pg', :group => :pg
+gem 'postgres', :group => :pg
@@ -8,7 +8,7 @@ GEM
activesupport (2.0.5)
mocha (0.9.12)
mysql (2.8.1)
- pg (0.11.0)
+ postgres (0.7.9.2008.01.28)
rake (0.8.7)
sqlite3 (1.3.4)
@@ -20,6 +20,6 @@ DEPENDENCIES
activerecord (~> 2.0.4)
mocha
mysql
- pg
+ postgres
rake (~> 0.8.7)
sqlite3
@@ -9,4 +9,4 @@ gem 'rake', '~> 0.8.7'
gem 'mocha'
gem 'sqlite3'
gem 'mysql', :group => :mysql
-gem 'pg', :group => :pg
+gem 'postgres', :group => :pg
@@ -8,7 +8,7 @@ GEM
activesupport (2.1.2)
mocha (0.9.12)
mysql (2.8.1)
- pg (0.11.0)
+ postgres (0.7.9.2008.01.28)
rake (0.8.7)
sqlite3 (1.3.4)
@@ -20,6 +20,6 @@ DEPENDENCIES
activerecord (~> 2.1.0)
mocha
mysql
- pg
+ postgres
rake (~> 0.8.7)
sqlite3
@@ -9,4 +9,4 @@ gem 'rake', '~> 0.8.7'
gem 'mocha'
gem 'sqlite3'
gem 'mysql', :group => :mysql
-gem 'pg', :group => :pg
+gem 'postgres', :group => :pg
@@ -8,7 +8,7 @@ GEM
activesupport (2.2.3)
mocha (0.9.12)
mysql (2.8.1)
- pg (0.11.0)
+ postgres (0.7.9.2008.01.28)
rake (0.8.7)
sqlite3 (1.3.4)
@@ -20,6 +20,6 @@ DEPENDENCIES
activerecord (~> 2.2.2)
mocha
mysql
- pg
+ postgres
rake (~> 0.8.7)
sqlite3

2 comments on commit 87eef6f

Hi Mislav,

do you remember the reason why did you use postgres instead of pg on this version?
Is there any issue related to this commit?

Owner

mislav replied Feb 12, 2013

I don't remember. The commit message says that pg was bust on 1.8.6, so it was probably that I was getting CI failures for that version.

Anyway, in the master branch I'm using "pg" again.

Please sign in to comment.