Skip to content

special characters are not allowed (jruby + 3.0.3 issue) #224

Closed
gudj opened this Issue Feb 1, 2012 · 11 comments

3 participants

@gudj
gudj commented Feb 1, 2012

I cannot install version 3.0.3, see error below. Version 3.0.2 does install.
I am using jruby 1.6.6 + rails 3.2.1 + will_paginate 3.0.3

/apps/p3$jruby -S gem install will_paginate -v '3.0.3'
Psych::SyntaxError: special characters are not allowed
parse at org/jruby/ext/psych/PsychParser.java:282
parse_stream at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/1.9/psych.rb:148
parse at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/1.9/psych.rb:119
load at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/1.9/psych.rb:106
from_yaml at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/specification.rb:490
load_gemspec at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:195
initialize at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:60
each at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb:64
loop at org/jruby/RubyKernel.java:1408
each at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb:55
initialize at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:35
open at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb:20
open at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/package.rb:44
from_io at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/format.rb:62
from_file_by_path at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/format.rb:46
open at org/jruby/RubyIO.java:1139
open at org/jruby/RubyKernel.java:297
from_file_by_path at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/format.rb:45
format at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/installer.rb:119
spec at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/installer.rb:129
ensure_required_ruby_version_met at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/installer.rb:386
install at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/installer.rb:156
install at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:297
each at org/jruby/RubyArray.java:1614
each_with_index at org/jruby/RubyEnumerable.java:956
install at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:270
execute at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:121
each at org/jruby/RubyArray.java:1614
execute at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:115
invoke at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/command.rb:278
process_args at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:147
run at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:117
run at /Library/Frameworks/JRuby.framework/Versions/Current/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:65
(root) at /Library/Frameworks/JRuby.framework/Versions/Current/bin/gem:21
/apps/p3$jruby -S gem install will_paginate -v '3.0.2'
Fetching: will_paginate-3.0.2.gem (100%)
Successfully installed will_paginate-3.0.2
1 gem installed
/apps/p3$

@msan
msan commented Feb 2, 2012

I have exactly the same problem.
My environment is:

jruby 1.6.6 (ruby-1.9.2-p312) (2012-01-30 5673572) (OpenJDK 64-Bit Server VM 1.6.0_24) [linux-amd64-java]

@mislav
Owner
mislav commented Feb 2, 2012
@msan
msan commented Feb 2, 2012
@mislav
Owner
mislav commented Feb 2, 2012
@msan
msan commented Feb 2, 2012
@msan
msan commented Feb 2, 2012
@mislav
Owner
mislav commented Feb 2, 2012

Maybe JRuby or rubygems bug? Nothing significant has changed between 3.0.2 and 3.0.3. Also, I can install the latest without problems, as I've said.

Paste the output of gem env, together with your OS info. I'll probably not be able to help much besides pointing you in the right direction. Also, how did you install JRuby?

@msan
msan commented Feb 3, 2012
@mislav
Owner
mislav commented Feb 8, 2012

I've commented there. I can't solve it since I didn't do anything wrong :)

@mislav mislav closed this Feb 8, 2012
@msan
msan commented Feb 8, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.