3.0.3 install error on Windows with chcp 932 #237

Closed
shirosaki opened this Issue Apr 2, 2012 · 1 comment

Comments

Projects
None yet
2 participants

I got the following strange error while installing on Windows XP with command prompt chcp 932.
invalid byte sequence in Windows-31J

With chcp 437, install succeeded.
With chcp 932, 3.0.2 install succeeded.

When using ruby 1.9.3 with chcp 932, 3.0.3 install succeeded.

>ruby -v
ruby 1.9.2p290 (2011-07-09) [i386-mingw32]

C:\>gem -v
1.7.2

>chcp
現在のコード ページ: 932

C:\>gem install -v 3.0.2 will_paginate
Fetching: will_paginate-3.0.2.gem (100%)
Successfully installed will_paginate-3.0.2
1 gem installed

>gem install -v 3.0.3 will_paginate
ERROR:  While executing gem ... (ArgumentError)
    invalid byte sequence in Windows-31J

>chcp 437

Active code page: 437
C:\>gem install -v 3.0.3 will_paginate
Successfully installed will_paginate-3.0.3
1 gem installed
Owner

mislav commented Jan 10, 2013

Sorry, don't know how I would debug this. The gem itself looks fine. Must be a problem of that specific environment. I don't even know what chcp is!

mislav closed this Jan 10, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment