Skip to content

Could not find mislav-will_paginate-2.3.16 in any of the sources #298

Closed
duncan-bayne opened this Issue Mar 7, 2013 · 2 comments

2 participants

@duncan-bayne

I'm trying to migrate a Rails 2.3 app to Bundler. Everything is working, except for mislav-will_paginate.

My Gemfile is as follows, using version 2.3.16 as per the installation docs:

source 'https://rubygems.org'

gem 'nokogiri', '1.4.2'
# snip
gem 'mislav-will_paginate', '~> 2.3.16'

group :development do
  gem 'rails-footnotes'
end

group :test do
  gem 'rspec'
  gem 'faker'
end

When I do a bundle install mislav-will_paginate fails with the following error:

Could not find mislav-will_paginate-2.3.16 in any of the sources
@mislav
Owner
mislav commented Mar 7, 2013

Hey there! The name of the gem is not "mislav-will_paginate", but just "will_paginate" (without the prefix).

Try it out with:

gem i will_paginate -v 2.3.16
@mislav mislav closed this Mar 7, 2013
@duncan-bayne

Hehe, thanks :) Shows how long it's been since this app has been upgraded .... I copied that Gem name straight from the config along with the others.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.