Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Problem in Production when I make deploy #352

Closed
bedomax opened this Issue Jan 16, 2014 · 2 comments

Comments

Projects
None yet
2 participants

bedomax commented Jan 16, 2014

Hi Guys

I am working with Rails 4 and I am using this Library in my pagination, but I have a problem when I make deploy in production, I see this error:


/home/deployer/apps/app/shared/bundle/ruby/1.9.1/gems/activesupport-4.0.0.rc1/lib/active_support/dependencies.rb:228:in require'/home/deployer/apps/app/shared/bundle/ruby/1.9.1/gems/activesupport-4.0.0.rc1/lib/active_support/dependencies.rb:228:inrequire': No such file to load -- will_paginate/array (LoadError)


In Develpment this library is working but in production I have this error, I was searching this error in Google but I can't find a solution.

Do you have any idea what may be wrong? Let me know when you find out please.

Thanks for you help.

Owner

mislav commented Jun 18, 2014

I have no idea why this doesn't work for you in production, but it's most likely an issue with the current gem bundle not being properly set up or "will_paginate" gem being missing after your deploy. Please double-check your configuration.

@mislav mislav closed this Jun 18, 2014

bedomax commented Jun 18, 2014

Hi Mislav

Yes, I could fix that issue. I had different versions the Ruby/Gem in my computer and other versions in the server.
I needed to have the same versions on my computer and server. I think that was the mistake.

Thanks for your answer.
Regards
Maximiliano

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment