New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incompatible with KeePass 2.39 #35

Open
mydexterid opened this Issue May 6, 2018 · 24 comments

Comments

Projects
None yet
@mydexterid
Copy link

mydexterid commented May 6, 2018

Latest release (7.6) is incompatible with KeePass 2.39.

@Suncatcher

This comment has been minimized.

Copy link

Suncatcher commented May 6, 2018

Confirm this.

image

@mitchcapper

This comment has been minimized.

Copy link
Owner

mitchcapper commented May 6, 2018

Thanks, this is confirmed as a valid bug KP changed something with the text entry box and I have been working to see about the next version still being compatible with < 2.39. Will hopefully have an update within the next few weeks.

@mitchcapper mitchcapper added the bug label May 6, 2018

@SanchoandPancho

This comment has been minimized.

Copy link

SanchoandPancho commented May 6, 2018

Hello,
sorry for my bad english. If it it possible, I wish an option to drag and drop the entries into formulars, because the order of formular fields in for e.g. registration formulars differs - and auto-fill doesn't fills correctly. I make a suggestion, because you're already make the plugin working for the new version and than its maybe possible to make drag and droppable.

Thanks.

@Suncatcher

This comment has been minimized.

Copy link

Suncatcher commented May 6, 2018

@SanchoandPancho you should create a new issue for this. This issue is purely incompatibility-wise

@TehPsychedelic

This comment has been minimized.

Copy link

TehPsychedelic commented May 7, 2018

Alright back to 2.38. Don't know about you guys but this plugin is basically the difference between a regular "nice try open source" application and a real proper competitor to 1Password and the real guys.

@mitchcapper

This comment has been minimized.

Copy link
Owner

mitchcapper commented May 7, 2018

Sorry! will hopefully have a new version out soon.

@mitchcapper

This comment has been minimized.

Copy link
Owner

mitchcapper commented May 11, 2018

Please test the sample plgx have in #39 assuming it goes well in test I will push the official version within the next few days.

@rangerxusa

This comment has been minimized.

Copy link

rangerxusa commented May 16, 2018

I tested the sample plgx v.7.8 beta and worked okay but noticed that a field defined as Rich TextBox with an OPT of 3 lines is actually showed 4 lines. Defining the a field using the older NOTES field defined with an OPT of 3 lines did show 3 lines.
This version still has a problem with unnecessary scroll bars in the edit template parent window but that is being addressed in another open issue.

@Suncatcher

This comment has been minimized.

Copy link

Suncatcher commented May 24, 2018

Still not released?

@Michael833

This comment has been minimized.

Copy link

Michael833 commented May 25, 2018

Does Dominik keep changing something that's breaking updates? So sorry, I know that updating can be annoying. Thank you for trying, we appreciate it.

@mitchcapper

This comment has been minimized.

Copy link
Owner

mitchcapper commented May 25, 2018

It was a breaking change in keepass that caused the incompatibility, they do not happen that often. You can download the package in #39 the second comment that works 100% with 2.39.1. The problem is the there are several other bugs that have been pointed out I want to try to fix before the next official release and some of them are a bit more puzzling so I have been having a hard time isolating the best solution.

@bmix

This comment has been minimized.

Copy link

bmix commented Jun 23, 2018

I had installed the beta from above and all was functioning. Then I rebooted the machine and I got the error again (strange enough), that is the reason for this current issue. I now downloaded the latest release from June 16 and I still get this error. I am using KeePass 2.39.1 on Win10.
kp

@tobby88

This comment has been minimized.

Copy link

tobby88 commented Jun 26, 2018

@bmix Works without problems here... Are you sure you used the right download? https://github.com/mitchcapper/KPEntryTemplates/files/1994132/KPEntryTemplates.zip

@bmix

This comment has been minimized.

Copy link

bmix commented Jun 27, 2018

Hmm... it seems I had another version. I just installed the one you linked to, and now all works fine! Thank you! Issue resolved for me.

@linkp

This comment has been minimized.

Copy link

linkp commented Jul 3, 2018

New version is working for me. Disregard previous feedback.

@kellerassel007

This comment has been minimized.

Copy link

kellerassel007 commented Jul 7, 2018

@nagyalex

This comment has been minimized.

Copy link

nagyalex commented Jul 18, 2018

I updated to https://github.com/mitchcapper/KPEntryTemplates/files/1994132/KPEntryTemplates.zip with Keepass 2.39.1. First error was shown.

Then I noticed for some reason I had copies of KPEntryTemplates.plgx in main program directory. After deleting them it works smoothly on Win 7.

@Suncatcher

This comment has been minimized.

Copy link

Suncatcher commented Aug 19, 2018

So what about update? For how long we should use dev release?

@jcamp

This comment has been minimized.

Copy link

jcamp commented Aug 23, 2018

Is there going to be a new release? The fix works so why not put into production?

@mitchcapper

This comment has been minimized.

Copy link
Owner

mitchcapper commented Sep 12, 2018

I committed some layout changes for keepass resize earlier as they looked sane but didn't test them as I didn't use that plugin. After testing it I found it is actually working pretty poorly and may degrade the normal UX. It is hard to test given some DPI requirements and the hardware I have access to currently.

As such I haven't released the update. I might just roll back the other commits to get it out.

@marcosimonegili

This comment has been minimized.

Copy link

marcosimonegili commented Oct 2, 2018

I updated to https://github.com/mitchcapper/KPEntryTemplates/files/1994132/KPEntryTemplates.zip with Keepass 2.39.1. First error was shown.
Then I noticed for some reason I had copies of KPEntryTemplates.plgx in main program directory. After deleting them it works smoothly on Win 7.

This version (7.8.0.0) of the Plugin also works on Win10 on KeePass 2.39.1 - Waiting for an official release! :)

@EdgewalkerBlue

This comment has been minimized.

Copy link

EdgewalkerBlue commented Oct 2, 2018

I updated to https://github.com/mitchcapper/KPEntryTemplates/files/1994132/KPEntryTemplates.zip with Keepass 2.39.1. First error was shown.
Then I noticed for some reason I had copies of KPEntryTemplates.plgx in main program directory. After deleting them it works smoothly on Win 7.

This version (7.8.0.0) of the Plugin also works on Win10 on KeePass 2.39.1 - Waiting for an official release! :)

This version (7.8.0.0) of the Plugin also works on Win10 on KeePass 2.40

@dev-pra

This comment has been minimized.

Copy link

dev-pra commented Oct 11, 2018

Thanks

@cpalm1974

This comment has been minimized.

Copy link

cpalm1974 commented Dec 6, 2018

Could you please issue a new release for the current KeePass version?
Now after so many months I found out that there is this working developer version. However I can't find a reason why this is not published so far as the GUI looks fine for me (although I haven't looked at it for almost a year now since upgrading to KeePass 2.39...).
Could you please give a hint in the readme.md for all for users that are forwarded to here from keepass.info since it gives the impression that KPEntryTemplates is a dead project (with the latest official release not working).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment