NixOS VBox.sh wrapper script confuses the VirtualBox version check #777

Closed
coreyoconnor opened this Issue Mar 7, 2012 · 5 comments

Projects

None yet

2 participants

@coreyoconnor

See the shell script here:
https://nixos.org/repos/nix/nixpkgs/trunk/pkgs/applications/virtualization/virtualbox/VBox.sh

--- pkgs/applications/virtualization/virtualbox/VBox.sh (revision 32610)
+++ pkgs/applications/virtualization/virtualbox/VBox.sh (working copy)
@@ -14,8 +14,6 @@
   exit 1
 fi

-echo "/dev/vboxdrv exists and $USER can access it."
-
 SERVER_PID=$(ps -U $USER | grep VBoxSVC | awk '{ print $1 }')
 if [ "$1" = "shutdown" ]; then
   if [ -n "$SERVER_PID" ]; then
@@ -60,7 +58,4 @@
   exit 1
 fi

-echo "VBoxSVC is running for user $USER with PID $SERVER_PID."
-
-echo "Starting $EXEC_APP."
 exec "$EXEC_APP" "$@"
@coreyoconnor

I presume that this could be resolved by the version check looking for any line that matches it's version parser.

@mitchellh
Owner

Oh, does this line go around every VBoxManage call?

@coreyoconnor

Yep! In addition to all other VirtualBox commands.

@mitchellh
Owner

It would help if you could send me some output of VBoxManage --version with the crap they added in. Thanks :)

@mitchellh
Owner

Closing due to lack of info.

@mitchellh mitchellh closed this Apr 7, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment