Permalink
Browse files

Correct build for older versions of python.

- Upgrade pip in place in case the system has an old version of pip
- Sync requirements.txt up with the download-cache requirements.txt had
  zope.configuration==3.7.3 and download-cache has version 3.7.4.
- Add john to the credits file
  • Loading branch information...
1 parent 7012ba2 commit 472e6fda5f1ac64bc28385d52a4f2490676d95a8 @jpschewe jpschewe committed with Apr 12, 2013
Showing with 4 additions and 1 deletion.
  1. +1 −0 CREDITS.txt
  2. +2 −0 Makefile
  3. +1 −1 requirements.txt
View
1 CREDITS.txt
@@ -11,3 +11,4 @@ Thanks to these people that have contributed code/assistance to bookie
- mikelietz
- Stéphane Klein
- Alexandre Gravel-Raymond
+- John Schewe
View
2 Makefile
@@ -129,6 +129,8 @@ deps: venv
then cd download-cache && git pull; \
else git clone "http://github.com/mitechie/bookie-download-cache.git" download-cache; \
fi
+ @echo "Making sure the latest version of pip is available"
+ $(PIP) install -U pip
$(PIP) install --no-index --no-dependencies --find-links file:///$(CACHE)/python -r requirements.txt
# TESTS
View
2 requirements.txt
@@ -58,7 +58,7 @@ unittest2==0.5.1
virtualenv==1.5.2
wsgiref==0.1.2
zope.component==3.10.0
-zope.configuration==3.7.3
+zope.configuration==3.7.4
zope.deprecation==3.5.0
zope.event==3.5.0-1
zope.i18nmessageid==3.5.3

0 comments on commit 472e6fd

Please sign in to comment.