Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 44 lines (35 sloc) 0.641 kB
454ffa2 @methane Use new container based Travis-CI
methane authored
1 sudo: false
2c8cbeb @msabramo Add .travis.yml
msabramo authored
2 language: python
3
4 python:
8149509 @mitsuhiko Fixed incorrect version definitions in travis
authored
5 - "2.6"
6 - "2.7"
7 - "pypy"
8 - "3.3"
8d97d71 @untitaker Metadata change
untitaker authored
9 - "3.4"
2c8cbeb @msabramo Add .travis.yml
msabramo authored
10
2740595 @mitsuhiko Changed build matrix for travis
authored
11 env:
12 - REQUIREMENTS=lowest
bc5e212 @mitsuhiko Added release requirements
authored
13 - REQUIREMENTS=release
2740595 @mitsuhiko Changed build matrix for travis
authored
14 - REQUIREMENTS=devel
15
16 matrix:
17 exclude:
d9ebac1 @mitsuhiko Flask should now work with release requirements on 3.3
authored
18 # Python 3 support currently does not work with lowest requirements
2740595 @mitsuhiko Changed build matrix for travis
authored
19 - python: "3.3"
20 env: REQUIREMENTS=lowest
df711ea @untitaker Some fixes
untitaker authored
21 - python: "3.4"
22 env: REQUIREMENTS=lowest
23
2740595 @mitsuhiko Changed build matrix for travis
authored
24
e9fa24c @mitsuhiko Make travis install development werkzeug
authored
25 install:
284081c @untitaker Don't pass version to tox explicitly
untitaker authored
26 - pip install tox
250247d @mitsuhiko Added install section
authored
27
8d97d71 @untitaker Metadata change
untitaker authored
28 script:
284081c @untitaker Don't pass version to tox explicitly
untitaker authored
29 - tox -e py-$REQUIREMENTS
6809ffc @mitsuhiko Don't build websites with travis
authored
30
31 branches:
32 except:
33 - website
b6f37c4 @mitsuhiko Updated travis config for notifications
authored
34
35 notifications:
36 email: false
1c8c21a @mitsuhiko Let travis notify the #pocoo irc channel
authored
37 irc:
38 channels:
39 - "chat.freenode.net#pocoo"
40 on_success: change
41 on_failure: always
42 use_notice: true
43 skip_join: true
Something went wrong with that request. Please try again.