Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Broken setup.py (SyntaxError:invalid syntax) #339

Closed
DenekUrich opened this Issue · 2 comments

2 participants

@DenekUrich
Downloading/unpacking Flask (from -r requirements.txt (line 1))
  Running setup.py egg_info for package Flask
    Traceback (most recent call last):
      File "", line 14, in 
      File "/home/denekurich/Projects/langoid.com/build/Flask/setup.py", line 62
        print "Audit requires PyFlakes installed in your system."""
                                                                ^
    SyntaxError: invalid syntax
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "", line 14, in 

  File "/home/denekurich/Projects/langoid.com/build/Flask/setup.py", line 62

    print "Audit requires PyFlakes installed in your system."""

                                                            ^

SyntaxError: invalid syntax
@DenekUrich

sorry, my mistake

@DenekUrich DenekUrich closed this
@martinml

If you arrive from Google to this issue like I did, what causes this is that you're running Python 3.x and Flask works only with 2.x :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.