Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

test_appcontext_signals() fails with blinker installed #781

Closed
Arfrever opened this Issue · 0 comments

1 participant

@Arfrever

test_appcontext_signals() fails with blinker installed. I use blinker 1.2. This failure occurs with Python 2.6, 2.7 and 3.3.

======================================================================
FAIL: test_appcontext_signals (flask.testsuite.signals.SignalsTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/flask/flask/testsuite/signals.py", line 118, in test_appcontext_signals
    self.assert_equal(recorded, ['push', 'pop'])
  File "/tmp/flask/flask/testsuite/__init__.py", line 139, in assert_equal
    return self.assertEqual(x, y)
AssertionError: Lists differ: ['push', 'push'] != ['push', 'pop']

First differing element 1:
push
pop

- ['push', 'push']
?            ^^^

+ ['push', 'pop']
?            ^^


@DasIch DasIch closed this issue from a commit
@DasIch DasIch Fix broken test_appcontext_signals test case
This fixes #781 and ensures that Flask is tested with blinker installed.
f88cc2d
@DasIch DasIch closed this in f88cc2d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.