Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Cannot easy_install Jinja2-2.6 #32

Open
dcrosta opened this Issue · 0 comments

1 participant

@dcrosta
$ easy_install "Jinja2 == 2.6"
Searching for Jinja2==2.6
Reading http://pypi.python.org/simple/Jinja2/
Reading http://jinja.pocoo.org/
No local packages or download links found for Jinja2==2.6
error: Could not find suitable distribution for Requirement.parse('Jinja2==2.6')
$ easy_install "Jinja2 == 2.6-dev"
Searching for Jinja2==2.6-dev
Reading http://pypi.python.org/simple/Jinja2/
Reading http://jinja.pocoo.org/
No local packages or download links found for Jinja2==2.6-dev
error: Could not find suitable distribution for Requirement.parse('Jinja2==2.6-dev')
$ easy_install "Jinja2 == dev"
Searching for Jinja2==dev
Reading http://pypi.python.org/simple/Jinja2/
Reading http://jinja.pocoo.org/
Best match: Jinja2 dev
Downloading http://dev.pocoo.org/hg/jinja2-main/archive/tip.zip#egg=Jinja2-dev
Processing tip.zip
error: Couldn't find a setup script in /var/folders/Y-/Y-Pm+QGfGpGZWZm14l2qW++++TI/-Tmp-/easy_install-TlhvGN/tip.zip

I think if the page at http://pypi.python.org/simple/Jinja2/ linked to the master branch's zipball, instead of to the old hg repository's tip.zip, this would work. For now, I've added this to my setup.py (in case anyone else runs into this problem):

      dependency_links=[
          'https://github.com/mitsuhiko/jinja2/zipball/master#egg=Jinja2-2.6dev',
      ]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.