Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

adding explicit mention of distribute prerequisite at runtime #168

Merged
merged 1 commit into from

2 participants

@mchesnut

(a couple of slight grammatical changes to the intro doc, too)

This is in response to issue #143

@mitsuhiko mitsuhiko merged commit d329a3e into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 18, 2012
This page is out of date. Refresh to see the latest.
Showing with 6 additions and 3 deletions.
  1. +6 −3 docs/intro.rst
View
9 docs/intro.rst
@@ -22,6 +22,9 @@ release with the debugsupport you will get a compiler error.
.. _ctypes: http://python.net/crew/theller/ctypes/
+If you wish to use the ``PackageLoader`` class, you will also need `distribute`_
+(formerly known as setuptools) installed at runtime.
+
Installation
------------
@@ -40,7 +43,7 @@ You can install the most recent Jinja2 version using `easy_install`_ or `pip`_::
This will install a Jinja2 egg in your Python installation's site-packages
directory.
-(If you are installing from the windows command line omit the `sudo` and make
+(If you are installing from the Windows command line omit the `sudo` and make
sure to run the command as user with administrator rights)
From the tarball release
@@ -50,7 +53,7 @@ From the tarball release
2. Unpack the tarball
3. ``sudo python setup.py install``
-Note that you either have to have setuptools or `distribute`_ installed,
+Note that you either have to have setuptools or `distribute`_ installed;
the latter is preferred.
This will install Jinja2 into your Python installation's site-packages directory.
@@ -98,7 +101,7 @@ Enable the debug support Module
By default Jinja2 will not compile the debug support module. Enabling this
will fail if you don't have the Python headers or a working compiler. This
-is often the case if you are installing Jinja2 from a windows machine.
+is often the case if you are installing Jinja2 from a Windows machine.
Because the debug support is only necessary for Python 2.4 you will not
have to do this unless you run 2.4::
Something went wrong with that request. Please try again.