non backwards-compatible with python 2.5 #5

Open
overratedpro opened this Issue Jan 25, 2012 · 1 comment

Comments

Projects
None yet
2 participants

fails with python2.5:

      File "/usr/local/pythonenv/API/lib/python2.5/site-packages/phpserialize.py", line 359
        s.write(b's:')
                    ^
    SyntaxError: invalid syntax

zigg commented Feb 23, 2012

1.2 works with Python 2.4, which I needed this module to run under.

Is it possible to revert the bytes stuff and use 2to3 to generate a Python 3 version instead? I have additional methods for reading PHP session files and would like to contribute them but I am not sure they are welcome against 1.2.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment