Skip to content

解决Debian 8运行apt get update时候的404错误

Mcl edited this page Apr 12, 2019 · 3 revisions

既然是404,那么更新一下可用源就能解决了:

cat <<EOF > /etc/apt/sources.list
deb http://archive.debian.org/debian/ jessie main
deb-src http://archive.debian.org/debian/ jessie main
deb http://security.debian.org jessie/updates main
deb-src http://security.debian.org jessie/updates main
EOF

apt-get clean
apt-get update

还有就是shadowsocks-libev安装命令得更新一下:

sh -c 'printf "deb http://archive.debian.org/debian jessie-backports main\n" > /etc/apt/sources.list.d/jessie-backports.list'
sh -c 'printf "deb http://archive.debian.org/debian jessie-backports-sloppy main" >> /etc/apt/sources.list.d/jessie-backports.list'
apt -o Acquire::Check-Valid-Until=false update
apt -t jessie-backports-sloppy install shadowsocks-libev

错误原因:

jessie-updates has been removed and jessie-backports has been archived

You can’t perform that action at this time.