Skip to content
Browse files

Checking in changes prior to tagging of version 0.03.

Changelog diff is:

diff --git a/Changes b/Changes
index 7e47344..b99e27a 100644
--- a/Changes
+++ b/Changes
@@ -1,5 +1,8 @@
 Revision history for Perl extension Plack::Middleware::File::Sass

+0.03  Sun Feb 13 19:40:10 PST 2011
+        - Use 'sass' gem executable if installed.
+
 0.02  Fri Feb 11 19:01:42 PST 2011
         - Supported SCSS with the new option 'syntax'
  • Loading branch information...
1 parent c03d63c commit 1eef64f5b11ebaf1bb3e059f64d4265a441fee3e @miyagawa committed Feb 13, 2011
Showing with 12 additions and 1 deletion.
  1. +3 −0 Changes
  2. +8 −0 README
  3. +1 −1 lib/Plack/Middleware/File/Sass.pm
View
3 Changes
@@ -1,5 +1,8 @@
Revision history for Perl extension Plack::Middleware::File::Sass
+0.03 Sun Feb 13 19:40:10 PST 2011
+ - Use 'sass' gem executable if installed.
+
0.02 Fri Feb 11 19:01:42 PST 2011
- Supported SCSS with the new option 'syntax'
View
8 README
@@ -33,6 +33,14 @@ DESCRIPTION
might want to precompile Sass templates to CSS files on disk and serves
them with a real web server like nginx or lighttpd.
+SASS BACKENDS
+ If you have the sass gem version higher than 3 installed and have the
+ "sass" executable available in your PATH, this module automatically uses
+ the command to convert Sass or SCSS into CSS. If the command is not
+ available and you have Text::Sass perl module available, it will be
+ used. Otherwise you'll get an exception during the initialization of
+ this middleware component.
+
OPTIONS
syntax
Defines which syntax to use. Valid values are *sass* and *scss*.
View
2 lib/Plack/Middleware/File/Sass.pm
@@ -2,7 +2,7 @@ package Plack::Middleware::File::Sass;
use strict;
use 5.008_001;
-our $VERSION = '0.02';
+our $VERSION = '0.03';
use parent qw(Plack::Middleware);
use Plack::Util::Accessor qw(sass syntax);

0 comments on commit 1eef64f

Please sign in to comment.
Something went wrong with that request. Please try again.