Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

1.5's -L can't handle conditional dependencies like Any::Moose #122

Closed
miyagawa opened this Issue Oct 13, 2011 · 1 comment

Comments

Projects
None yet
1 participant
Owner

miyagawa commented Oct 13, 2011

The way scanning dependencies have been changed, and modules that does eval require inside Makefile.PL to handle optional dependencies do not work properly. One of the example is Any::Moose, because if you have Moose installed already, it won't add Mouse as a dependency, and end up pulling nothing in the isolated local::lib path.

https://gist.github.com/1283174

Owner

miyagawa commented Oct 13, 2011

Current workaround is for end users (you) to install Moose/Mouse specifically, in the case of Any::Moose.

@miyagawa miyagawa closed this Aug 4, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment