New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Match gem version when multiple versions installed #125

Merged
merged 1 commit into from May 22, 2013

Conversation

Projects
None yet
2 participants
@johanek
Contributor

johanek commented May 22, 2013

Hey,

If I've got multiple gems installed, the version check fails as it's looking for the version number surrounded by brackets.

I've got situations where I've legitimately got multiple versions of gems installed, but I still want to check a specific version is installed.

Maybe you want to keep the behaviour of matching only a single version, perhaps there could be something like including_version(version) for the scenario I have?

@mizzy

This comment has been minimized.

Show comment
Hide comment
@mizzy

mizzy May 22, 2013

Owner

Oh, I missed the situation of multiple versions.Your code is correct.Thanks!

Owner

mizzy commented May 22, 2013

Oh, I missed the situation of multiple versions.Your code is correct.Thanks!

@mizzy mizzy merged commit f02c61f into mizzy:master May 22, 2013

1 check passed

default The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment