fails to install on Perl 5.20 #12

Open
abraxxa opened this Issue May 27, 2014 · 22 comments

Comments

Projects
None yet
@abraxxa

abraxxa commented May 27, 2014

Looks like the warning message has changed slightly:

cpanm (App::cpanminus) 1.7004 on perl 5.020000 built for x86_64-linux-thread-multi
Work directory is /home/ahartmai/.cpanm/work/1401215078.15593
You have make /usr/bin/make
You have LWP 6.06
You have /bin/tar: tar (GNU tar) 1.27.1
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.
You have /usr/bin/unzip
Searching MooseX::App::Cmd on cpanmetadb ...
--> Working on MooseX::App::Cmd
Fetching http://www.cpan.org/authors/id/M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
-> OK
Unpacking MooseX-App-Cmd-0.27.tar.gz
Entering MooseX-App-Cmd-0.27
Checking configure dependencies from META.json
Checking if you have ExtUtils::MakeMaker 6.30 ... Yes (6.98)
Configuring MooseX-App-Cmd-0.27
Running Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for MooseX::App::Cmd
Writing MYMETA.yml and MYMETA.json
-> OK
Checking dependencies from MYMETA.json ...
Checking if you have strict 0 ... Yes (1.08)
Checking if you have warnings 0 ... Yes (1.23)
Checking if you have Test::Output 0 ... Yes (1.03)
Checking if you have YAML 0 ... Yes (0.90)
Checking if you have App::Cmd::Command 0 ... Yes (0.323)
Checking if you have Any::Moose 0 ... Yes (0.21)
Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98)
Checking if you have Test::More 0.94 ... Yes (1.001003)
Checking if you have lib 0 ... Yes (0.63)
Checking if you have App::Cmd 0.321 ... Yes (0.323)
Checking if you have Getopt::Long::Descriptive 0.091 ... Yes (0.097)
Checking if you have Scalar::Util 0 ... Yes (1.38)
Checking if you have File::Spec 0 ... Yes (3.47)
Checking if you have File::Basename 0 ... Yes (2.85)
Checking if you have base 0 ... Yes (2.22)
Checking if you have IPC::Open3 0 ... Yes (1.16)
Checking if you have English 0 ... Yes (1.09)
Checking if you have namespace::clean 0 ... Yes (0.25)
Checking if you have Carp 0 ... Yes (1.3301)
Checking if you have Data::Dumper 0 ... Yes (2.151)
Checking if you have MouseX::Getopt 0 ... Yes (0.35)
Checking if you have IO::Handle 0 ... Yes (1.35)
Checking if you have Test::use::ok 0 ... Yes (0.11)
Building and testing MooseX-App-Cmd-0.27
cp lib/MouseX/App/Cmd.pm blib/lib/MouseX/App/Cmd.pm
cp lib/MooseX/App/Cmd/Command.pm blib/lib/MooseX/App/Cmd/Command.pm
cp lib/MouseX/App/Cmd/Command.pm blib/lib/MouseX/App/Cmd/Command.pm
cp lib/MooseX/App/Cmd.pm blib/lib/MooseX/App/Cmd.pm
Manifying blib/man3/MooseX::App::Cmd.3
Manifying blib/man3/MooseX::App::Cmd::Command.3
Manifying blib/man3/MouseX::App::Cmd.3
Manifying blib/man3/MouseX::App::Cmd::Command.3
PERL_DL_NONLAZY=1 /home/ahartmai/perl5/perlbrew/perls/20/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/.t
t/00-compile.t .......................... ok

Testing with Perl 5.020000, /home/ahartmai/perl5/perlbrew/perls/20/bin/perl

Any::Moose version is 0.21

App::Cmd version is 0.323

App::Cmd::Command version is 0.323

Carp version is 1.3301

Data::Dumper version is 2.151

English version is 1.09

ExtUtils::MakeMaker version is 6.98

File::Basename version is 2.85

File::Spec version is 3.47

Getopt::Long::Descriptive version is 0.097

IO::Handle version is 1.35

IPC::Open3 version is 1.16

MouseX::Getopt version is 0.35

Scalar::Util version is 1.38

Test::More version is 1.001003

Test::Output version is 1.03

Test::use::ok version is 0.11

YAML version is 0.90

base version is 2.22

lib version is 0.63

namespace::clean version is 0.25

strict version is 1.08

warnings version is 1.23

t/000-report-versions.t ................. ok
t/author-critic.t ....................... skipped: these tests are for testing by the author
t/author-test-eol.t ..................... skipped: these tests are for testing by the author

Failed test 'required option field is missing'

at t/basic.t line 71.

'Mandatory parameter 'wow' missing in call to "eval"

basic.t bark [-?] [long options...]

--wow required option field

-? --usage --help Prints this usage information.

'

doesn't match '(?^:Mandatory parameter 'wow' missing in call to (eval))'

Looks like you failed 1 test of 12.

t/basic.t ...............................
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests
t/build_emulates_new.t .................. ok

Failed test 'command died with the correct string'

at t/configfile.t line 28.

'Mandatory parameter 'moo' missing in call to "eval"

configfile.t moo [-?] [long options...]

--configfile

--moo required option field

-? --usage --help Prints this usage information.

'

doesn't match '(?^:Mandatory parameter 'moo' missing in call to (eval))'

Looks like you failed 1 test of 3.

t/configfile.t ..........................
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests
t/moose.t ............................... ok
t/mouse.t ............................... ok
t/release-changes_has_content.t ......... skipped: these tests are for release candidate testing
t/release-cpan-changes.t ................ skipped: these tests are for release candidate testing
t/release-dist-manifest.t ............... skipped: these tests are for release candidate testing
t/release-distmeta.t .................... skipped: these tests are for release candidate testing
t/release-kwalitee.t .................... skipped: these tests are for release candidate testing
t/release-localbrew-perl-latest-TEST.t .. skipped: these tests are for release candidate testing
t/release-meta-json.t ................... skipped: these tests are for release candidate testing
t/release-minimum-version.t ............. skipped: these tests are for release candidate testing
t/release-mojibake.t .................... skipped: these tests are for release candidate testing
t/release-no-tabs.t ..................... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ................ skipped: these tests are for release candidate testing
t/release-pod-linkcheck.t ............... skipped: these tests are for release candidate testing
t/release-pod-syntax.t .................. skipped: these tests are for release candidate testing
t/release-portability.t ................. skipped: these tests are for release candidate testing
t/release-synopsis.t .................... skipped: these tests are for release candidate testing
t/release-test-version.t ................ skipped: these tests are for release candidate testing
t/release-unused-vars.t ................. skipped: these tests are for release candidate testing

Test Summary Report

t/basic.t (Wstat: 256 Tests: 12 Failed: 1)
Failed test: 7
Non-zero exit status: 1
t/configfile.t (Wstat: 256 Tests: 3 Failed: 1)
Failed test: 1
Non-zero exit status: 1
Files=26, Tests=47, 2 wallclock secs ( 0.14 usr 0.04 sys + 1.64 cusr 0.20 csys = 2.02 CPU)
Result: FAIL
Failed 2/26 test programs. 2/47 subtests failed.
make: *** [test_dynamic] Error 255
-> FAIL Installing MooseX::App::Cmd failed. See /home/ahartmai/.cpanm/work/1401215078.15593/build.log for details. Retry with --force to force install it.

@karenetheridge

This comment has been minimized.

Show comment Hide comment
@karenetheridge

karenetheridge May 28, 2014

Could you possibly edit this ticket to indent the output by four columns? it's really hard to read right now.

Could you possibly edit this ticket to indent the output by four columns? it's really hard to read right now.

@tobyink

This comment has been minimized.

Show comment Hide comment
@tobyink

tobyink May 28, 2014

Or just add:

```

... to the top and bottom.

tobyink commented May 28, 2014

Or just add:

```

... to the top and bottom.

@mjgardner

This comment has been minimized.

Show comment Hide comment
@mjgardner

mjgardner May 29, 2014

Owner

Sorry for the delays, have been heads-down on a $work project. I will try to deal with this ASAP before the week is out.

Owner

mjgardner commented May 29, 2014

Sorry for the delays, have been heads-down on a $work project. I will try to deal with this ASAP before the week is out.

@jomo666

This comment has been minimized.

Show comment Hide comment
@jomo666

jomo666 Jun 1, 2014

I got this:

cpanm (App::cpanminus) 1.7001 on perl 5.020000 built for darwin-2level
Work directory is /Users/jm/.cpanm/work/1401615154.59314
You have make /usr/bin/make
You have LWP 6.06
You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3
You have /usr/bin/unzip
Searching MooseX::App::Cmd on cpanmetadb ...
--> Working on MooseX::App::Cmd
Fetching http://www.cpan.org/authors/id/M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
-> OK
Unpacking MooseX-App-Cmd-0.27.tar.gz
Entering MooseX-App-Cmd-0.27
Checking configure dependencies from META.json
Checking if you have ExtUtils::MakeMaker 6.30 ... Yes (6.98)
Configuring MooseX-App-Cmd-0.27
Running Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for MooseX::App::Cmd
Writing MYMETA.yml and MYMETA.json
-> OK
Checking dependencies from MYMETA.json ...
Checking if you have Test::use::ok 0 ... Yes (0.11)
Checking if you have Getopt::Long::Descriptive 0.091 ... Yes (0.097)
Checking if you have Test::Output 0 ... Yes (1.03)
Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98)
Checking if you have lib 0 ... Yes (0.63)
Checking if you have YAML 0 ... Yes (0.92)
Checking if you have File::Spec 0 ... Yes (3.47)
Checking if you have MouseX::Getopt 0 ... Yes (0.35)
Checking if you have App::Cmd 0.321 ... Yes (0.323)
Checking if you have namespace::clean 0 ... Yes (0.25)
Checking if you have App::Cmd::Command 0 ... Yes (0.323)
Checking if you have Any::Moose 0 ... Yes (0.21)
Checking if you have warnings 0 ... Yes (1.23)
Checking if you have Test::More 0.94 ... Yes (1.001003)
Checking if you have Scalar::Util 0 ... Yes (1.38)
Checking if you have File::Basename 0 ... Yes (2.85)
Checking if you have strict 0 ... Yes (1.08)
Checking if you have IO::Handle 0 ... Yes (1.35)
Checking if you have base 0 ... Yes (2.22)
Checking if you have English 0 ... Yes (1.09)
Checking if you have IPC::Open3 0 ... Yes (1.16)
Checking if you have Data::Dumper 0 ... Yes (2.151)
Checking if you have Carp 0 ... Yes (1.3301)
Building and testing MooseX-App-Cmd-0.27
cp lib/MooseX/App/Cmd.pm blib/lib/MooseX/App/Cmd.pm
cp lib/MouseX/App/Cmd/Command.pm blib/lib/MouseX/App/Cmd/Command.pm
cp lib/MooseX/App/Cmd/Command.pm blib/lib/MooseX/App/Cmd/Command.pm
cp lib/MouseX/App/Cmd.pm blib/lib/MouseX/App/Cmd.pm
Manifying blib/man3/MooseX::App::Cmd.3
Manifying blib/man3/MooseX::App::Cmd::Command.3
Manifying blib/man3/MouseX::App::Cmd.3
Manifying blib/man3/MouseX::App::Cmd::Command.3
PERL_DL_NONLAZY=1 /Users/jm/perl5/perlbrew/perls/perl-5.20.0/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t .......................... ok
# Testing with Perl 5.020000, /Users/jm/perl5/perlbrew/perls/perl-5.20.0/bin/perl
#     Any::Moose version is 0.21
#     App::Cmd version is 0.323
#     App::Cmd::Command version is 0.323
#     Carp version is 1.3301
#     Data::Dumper version is 2.151
#     English version is 1.09
#     ExtUtils::MakeMaker version is 6.98
#     File::Basename version is 2.85
#     File::Spec version is 3.47
#     Getopt::Long::Descriptive version is 0.097
#     IO::Handle version is 1.35
#     IPC::Open3 version is 1.16
#     MouseX::Getopt version is 0.35
#     Scalar::Util version is 1.38
#     Test::More version is 1.001003
#     Test::Output version is 1.03
#     Test::use::ok version is 0.11
#     YAML version is 0.92
#     base version is 2.22
#     lib version is 0.63
#     namespace::clean version is 0.25
#     strict version is 1.08
#     warnings version is 1.23
t/000-report-versions.t ................. ok
t/author-critic.t ....................... skipped: these tests are for testing by the author
t/author-test-eol.t ..................... skipped: these tests are for testing by the author

#   Failed test 'required option field is missing'
#   at t/basic.t line 71.
#                   'Mandatory parameter 'wow' missing in call to "eval"
# 
# basic.t bark [-?] [long options...]
#   --wow              required option field
#   -? --usage --help  Prints this usage information.
# '
#     doesn't match '(?^:Mandatory parameter 'wow' missing in call to \(eval\))'
# Looks like you failed 1 test of 12.
t/basic.t ............................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests 
t/build_emulates_new.t .................. ok

#   Failed test 'command died with the correct string'
#   at t/configfile.t line 28.
#                   'Mandatory parameter 'moo' missing in call to "eval"
# 
# configfile.t moo [-?] [long options...]
#   --configfile        
#   -? --usage --help  Prints this usage information.
#   --moo              required option field
# '
#     doesn't match '(?^:Mandatory parameter 'moo' missing in call to \(eval\))'
# Looks like you failed 1 test of 3.
t/configfile.t .......................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
t/moose.t ............................... skipped: Moose and MooseX::Getopt required to test Moose usage
t/mouse.t ............................... ok
t/release-changes_has_content.t ......... skipped: these tests are for release candidate testing
t/release-cpan-changes.t ................ skipped: these tests are for release candidate testing
t/release-dist-manifest.t ............... skipped: these tests are for release candidate testing
t/release-distmeta.t .................... skipped: these tests are for release candidate testing
t/release-kwalitee.t .................... skipped: these tests are for release candidate testing
t/release-localbrew-perl-latest-TEST.t .. skipped: these tests are for release candidate testing
t/release-meta-json.t ................... skipped: these tests are for release candidate testing
t/release-minimum-version.t ............. skipped: these tests are for release candidate testing
t/release-mojibake.t .................... skipped: these tests are for release candidate testing
t/release-no-tabs.t ..................... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ................ skipped: these tests are for release candidate testing
t/release-pod-linkcheck.t ............... skipped: these tests are for release candidate testing
t/release-pod-syntax.t .................. skipped: these tests are for release candidate testing
t/release-portability.t ................. skipped: these tests are for release candidate testing
t/release-synopsis.t .................... skipped: these tests are for release candidate testing
t/release-test-version.t ................ skipped: these tests are for release candidate testing
t/release-unused-vars.t ................. skipped: these tests are for release candidate testing

Test Summary Report
-------------------
t/basic.t                             (Wstat: 256 Tests: 12 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/configfile.t                        (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=26, Tests=45,  4 wallclock secs ( 0.11 usr  0.09 sys +  2.23 cusr  0.44 csys =  2.87 CPU)
Result: FAIL
Failed 2/26 test programs. 2/45 subtests failed.
make: *** [test_dynamic] Error 255
-> FAIL Installing MooseX::App::Cmd failed. See /Users/jm/.cpanm/work/1401615154.59314/build.log for details. Retry with --force to force install it.

jomo666 commented Jun 1, 2014

I got this:

cpanm (App::cpanminus) 1.7001 on perl 5.020000 built for darwin-2level
Work directory is /Users/jm/.cpanm/work/1401615154.59314
You have make /usr/bin/make
You have LWP 6.06
You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3
You have /usr/bin/unzip
Searching MooseX::App::Cmd on cpanmetadb ...
--> Working on MooseX::App::Cmd
Fetching http://www.cpan.org/authors/id/M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
-> OK
Unpacking MooseX-App-Cmd-0.27.tar.gz
Entering MooseX-App-Cmd-0.27
Checking configure dependencies from META.json
Checking if you have ExtUtils::MakeMaker 6.30 ... Yes (6.98)
Configuring MooseX-App-Cmd-0.27
Running Makefile.PL
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for MooseX::App::Cmd
Writing MYMETA.yml and MYMETA.json
-> OK
Checking dependencies from MYMETA.json ...
Checking if you have Test::use::ok 0 ... Yes (0.11)
Checking if you have Getopt::Long::Descriptive 0.091 ... Yes (0.097)
Checking if you have Test::Output 0 ... Yes (1.03)
Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.98)
Checking if you have lib 0 ... Yes (0.63)
Checking if you have YAML 0 ... Yes (0.92)
Checking if you have File::Spec 0 ... Yes (3.47)
Checking if you have MouseX::Getopt 0 ... Yes (0.35)
Checking if you have App::Cmd 0.321 ... Yes (0.323)
Checking if you have namespace::clean 0 ... Yes (0.25)
Checking if you have App::Cmd::Command 0 ... Yes (0.323)
Checking if you have Any::Moose 0 ... Yes (0.21)
Checking if you have warnings 0 ... Yes (1.23)
Checking if you have Test::More 0.94 ... Yes (1.001003)
Checking if you have Scalar::Util 0 ... Yes (1.38)
Checking if you have File::Basename 0 ... Yes (2.85)
Checking if you have strict 0 ... Yes (1.08)
Checking if you have IO::Handle 0 ... Yes (1.35)
Checking if you have base 0 ... Yes (2.22)
Checking if you have English 0 ... Yes (1.09)
Checking if you have IPC::Open3 0 ... Yes (1.16)
Checking if you have Data::Dumper 0 ... Yes (2.151)
Checking if you have Carp 0 ... Yes (1.3301)
Building and testing MooseX-App-Cmd-0.27
cp lib/MooseX/App/Cmd.pm blib/lib/MooseX/App/Cmd.pm
cp lib/MouseX/App/Cmd/Command.pm blib/lib/MouseX/App/Cmd/Command.pm
cp lib/MooseX/App/Cmd/Command.pm blib/lib/MooseX/App/Cmd/Command.pm
cp lib/MouseX/App/Cmd.pm blib/lib/MouseX/App/Cmd.pm
Manifying blib/man3/MooseX::App::Cmd.3
Manifying blib/man3/MooseX::App::Cmd::Command.3
Manifying blib/man3/MouseX::App::Cmd.3
Manifying blib/man3/MouseX::App::Cmd::Command.3
PERL_DL_NONLAZY=1 /Users/jm/perl5/perlbrew/perls/perl-5.20.0/bin/perl "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t .......................... ok
# Testing with Perl 5.020000, /Users/jm/perl5/perlbrew/perls/perl-5.20.0/bin/perl
#     Any::Moose version is 0.21
#     App::Cmd version is 0.323
#     App::Cmd::Command version is 0.323
#     Carp version is 1.3301
#     Data::Dumper version is 2.151
#     English version is 1.09
#     ExtUtils::MakeMaker version is 6.98
#     File::Basename version is 2.85
#     File::Spec version is 3.47
#     Getopt::Long::Descriptive version is 0.097
#     IO::Handle version is 1.35
#     IPC::Open3 version is 1.16
#     MouseX::Getopt version is 0.35
#     Scalar::Util version is 1.38
#     Test::More version is 1.001003
#     Test::Output version is 1.03
#     Test::use::ok version is 0.11
#     YAML version is 0.92
#     base version is 2.22
#     lib version is 0.63
#     namespace::clean version is 0.25
#     strict version is 1.08
#     warnings version is 1.23
t/000-report-versions.t ................. ok
t/author-critic.t ....................... skipped: these tests are for testing by the author
t/author-test-eol.t ..................... skipped: these tests are for testing by the author

#   Failed test 'required option field is missing'
#   at t/basic.t line 71.
#                   'Mandatory parameter 'wow' missing in call to "eval"
# 
# basic.t bark [-?] [long options...]
#   --wow              required option field
#   -? --usage --help  Prints this usage information.
# '
#     doesn't match '(?^:Mandatory parameter 'wow' missing in call to \(eval\))'
# Looks like you failed 1 test of 12.
t/basic.t ............................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests 
t/build_emulates_new.t .................. ok

#   Failed test 'command died with the correct string'
#   at t/configfile.t line 28.
#                   'Mandatory parameter 'moo' missing in call to "eval"
# 
# configfile.t moo [-?] [long options...]
#   --configfile        
#   -? --usage --help  Prints this usage information.
#   --moo              required option field
# '
#     doesn't match '(?^:Mandatory parameter 'moo' missing in call to \(eval\))'
# Looks like you failed 1 test of 3.
t/configfile.t .......................... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
t/moose.t ............................... skipped: Moose and MooseX::Getopt required to test Moose usage
t/mouse.t ............................... ok
t/release-changes_has_content.t ......... skipped: these tests are for release candidate testing
t/release-cpan-changes.t ................ skipped: these tests are for release candidate testing
t/release-dist-manifest.t ............... skipped: these tests are for release candidate testing
t/release-distmeta.t .................... skipped: these tests are for release candidate testing
t/release-kwalitee.t .................... skipped: these tests are for release candidate testing
t/release-localbrew-perl-latest-TEST.t .. skipped: these tests are for release candidate testing
t/release-meta-json.t ................... skipped: these tests are for release candidate testing
t/release-minimum-version.t ............. skipped: these tests are for release candidate testing
t/release-mojibake.t .................... skipped: these tests are for release candidate testing
t/release-no-tabs.t ..................... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ................ skipped: these tests are for release candidate testing
t/release-pod-linkcheck.t ............... skipped: these tests are for release candidate testing
t/release-pod-syntax.t .................. skipped: these tests are for release candidate testing
t/release-portability.t ................. skipped: these tests are for release candidate testing
t/release-synopsis.t .................... skipped: these tests are for release candidate testing
t/release-test-version.t ................ skipped: these tests are for release candidate testing
t/release-unused-vars.t ................. skipped: these tests are for release candidate testing

Test Summary Report
-------------------
t/basic.t                             (Wstat: 256 Tests: 12 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/configfile.t                        (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=26, Tests=45,  4 wallclock secs ( 0.11 usr  0.09 sys +  2.23 cusr  0.44 csys =  2.87 CPU)
Result: FAIL
Failed 2/26 test programs. 2/45 subtests failed.
make: *** [test_dynamic] Error 255
-> FAIL Installing MooseX::App::Cmd failed. See /Users/jm/.cpanm/work/1401615154.59314/build.log for details. Retry with --force to force install it.

@sschober

This comment has been minimized.

Show comment Hide comment
@sschober

sschober Jun 16, 2014

The same here, on 5.21.0 and 5.18.2. So, maybe the perl version is not the problem, but a recently updated module?

Running make for M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  Has already been unwrapped into directory /home/sven/.cpan/build/MooseX-App-Cmd-0.27-r3U793

  CPAN.pm: Building M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz

cp lib/MouseX/App/Cmd.pm blib/lib/MouseX/App/Cmd.pm
cp lib/MooseX/App/Cmd/Command.pm blib/lib/MooseX/App/Cmd/Command.pm
cp lib/MooseX/App/Cmd.pm blib/lib/MooseX/App/Cmd.pm
cp lib/MouseX/App/Cmd/Command.pm blib/lib/MouseX/App/Cmd/Command.pm
Manifying blib/man3/MouseX::App::Cmd::Command.3
Manifying blib/man3/MooseX::App::Cmd.3
Manifying blib/man3/MooseX::App::Cmd::Command.3
Manifying blib/man3/MouseX::App::Cmd.3
  MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  /usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 /opt/perl5/perls/perl-5.18.2/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t .......................... ok   
t/000-report-versions.t ................. # Testing with Perl 5.018002, /opt/perl5/perls/perl-5.18.2/bin/perl
t/000-report-versions.t ................. 1/? #     Any::Moose version is 0.21
#     App::Cmd version is 0.323
#     App::Cmd::Command version is 0.323
#     Carp version is 1.29
#     Data::Dumper version is 2.145
#     English version is 1.06_01
#     ExtUtils::MakeMaker version is 6.66
#     File::Basename version is 2.84
#     File::Spec version is 3.40
#     Getopt::Long::Descriptive version is 0.097
#     IO::Handle version is 1.34
#     IPC::Open3 version is 1.13
#     MouseX::Getopt version is 0.35
#     Scalar::Util version is 1.27
#     Test::More version is 1.001003
#     Test::Output version is 1.03
#     Test::use::ok version is 0.11
#     YAML version is 0.94
#     base version is 2.18
#     lib version is 0.63
#     namespace::clean version is 0.25
#     strict version is 1.07
#     warnings version is 1.18
t/000-report-versions.t ................. ok    
t/author-critic.t ....................... skipped: these tests are for testing by the author
t/author-test-eol.t ..................... skipped: these tests are for testing by the author
t/basic.t ............................... 1/12 
#   Failed test 'required option field is missing'
#   at t/basic.t line 71.
#                   'Mandatory parameter 'wow' missing in call to "eval"
# 
# basic.t bark [-?] [long options...]
#   --wow              required option field
#   -? --usage --help  Prints this usage information.
# '
#     doesn't match '(?^:Mandatory parameter 'wow' missing in call to \(eval\))'
# Looks like you failed 1 test of 12.
t/basic.t ............................... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests 
t/build_emulates_new.t .................. ok   
t/configfile.t .......................... 1/3 
#   Failed test 'command died with the correct string'
#   at t/configfile.t line 28.
#                   'Mandatory parameter 'moo' missing in call to "eval"
# 
# configfile.t moo [-?] [long options...]
#   -? --usage --help  Prints this usage information.
#   --configfile        
#   --moo              required option field
# '
#     doesn't match '(?^:Mandatory parameter 'moo' missing in call to \(eval\))'
# Looks like you failed 1 test of 3.
t/configfile.t .......................... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
t/moose.t ............................... skipped: Moose and MooseX::Getopt required to test Moose usage
t/mouse.t ............................... ok   
t/release-changes_has_content.t ......... skipped: these tests are for release candidate testing
t/release-cpan-changes.t ................ skipped: these tests are for release candidate testing
t/release-dist-manifest.t ............... skipped: these tests are for release candidate testing
t/release-distmeta.t .................... skipped: these tests are for release candidate testing
t/release-kwalitee.t .................... skipped: these tests are for release candidate testing
t/release-localbrew-perl-latest-TEST.t .. skipped: these tests are for release candidate testing
t/release-meta-json.t ................... skipped: these tests are for release candidate testing
t/release-minimum-version.t ............. skipped: these tests are for release candidate testing
t/release-mojibake.t .................... skipped: these tests are for release candidate testing
t/release-no-tabs.t ..................... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ................ skipped: these tests are for release candidate testing
t/release-pod-linkcheck.t ............... skipped: these tests are for release candidate testing
t/release-pod-syntax.t .................. skipped: these tests are for release candidate testing
t/release-portability.t ................. skipped: these tests are for release candidate testing
t/release-synopsis.t .................... skipped: these tests are for release candidate testing
t/release-test-version.t ................ skipped: these tests are for release candidate testing
t/release-unused-vars.t ................. skipped: these tests are for release candidate testing

Test Summary Report
-------------------
t/basic.t                             (Wstat: 256 Tests: 12 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/configfile.t                        (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=26, Tests=45,  1 wallclock secs ( 0.05 usr  0.02 sys +  0.89 cusr  0.06 csys =  1.02 CPU)
Result: FAIL
Failed 2/26 test programs. 2/45 subtests failed.
Makefile:887: recipe for target 'test_dynamic' failed
make: *** [test_dynamic] Error 255
  MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  /usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
Running make install
  make test had returned bad status, won't install without force

The same here, on 5.21.0 and 5.18.2. So, maybe the perl version is not the problem, but a recently updated module?

Running make for M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  Has already been unwrapped into directory /home/sven/.cpan/build/MooseX-App-Cmd-0.27-r3U793

  CPAN.pm: Building M/MJ/MJGARDNER/MooseX-App-Cmd-0.27.tar.gz

cp lib/MouseX/App/Cmd.pm blib/lib/MouseX/App/Cmd.pm
cp lib/MooseX/App/Cmd/Command.pm blib/lib/MooseX/App/Cmd/Command.pm
cp lib/MooseX/App/Cmd.pm blib/lib/MooseX/App/Cmd.pm
cp lib/MouseX/App/Cmd/Command.pm blib/lib/MouseX/App/Cmd/Command.pm
Manifying blib/man3/MouseX::App::Cmd::Command.3
Manifying blib/man3/MooseX::App::Cmd.3
Manifying blib/man3/MooseX::App::Cmd::Command.3
Manifying blib/man3/MouseX::App::Cmd.3
  MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  /usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 /opt/perl5/perls/perl-5.18.2/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t .......................... ok   
t/000-report-versions.t ................. # Testing with Perl 5.018002, /opt/perl5/perls/perl-5.18.2/bin/perl
t/000-report-versions.t ................. 1/? #     Any::Moose version is 0.21
#     App::Cmd version is 0.323
#     App::Cmd::Command version is 0.323
#     Carp version is 1.29
#     Data::Dumper version is 2.145
#     English version is 1.06_01
#     ExtUtils::MakeMaker version is 6.66
#     File::Basename version is 2.84
#     File::Spec version is 3.40
#     Getopt::Long::Descriptive version is 0.097
#     IO::Handle version is 1.34
#     IPC::Open3 version is 1.13
#     MouseX::Getopt version is 0.35
#     Scalar::Util version is 1.27
#     Test::More version is 1.001003
#     Test::Output version is 1.03
#     Test::use::ok version is 0.11
#     YAML version is 0.94
#     base version is 2.18
#     lib version is 0.63
#     namespace::clean version is 0.25
#     strict version is 1.07
#     warnings version is 1.18
t/000-report-versions.t ................. ok    
t/author-critic.t ....................... skipped: these tests are for testing by the author
t/author-test-eol.t ..................... skipped: these tests are for testing by the author
t/basic.t ............................... 1/12 
#   Failed test 'required option field is missing'
#   at t/basic.t line 71.
#                   'Mandatory parameter 'wow' missing in call to "eval"
# 
# basic.t bark [-?] [long options...]
#   --wow              required option field
#   -? --usage --help  Prints this usage information.
# '
#     doesn't match '(?^:Mandatory parameter 'wow' missing in call to \(eval\))'
# Looks like you failed 1 test of 12.
t/basic.t ............................... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/12 subtests 
t/build_emulates_new.t .................. ok   
t/configfile.t .......................... 1/3 
#   Failed test 'command died with the correct string'
#   at t/configfile.t line 28.
#                   'Mandatory parameter 'moo' missing in call to "eval"
# 
# configfile.t moo [-?] [long options...]
#   -? --usage --help  Prints this usage information.
#   --configfile        
#   --moo              required option field
# '
#     doesn't match '(?^:Mandatory parameter 'moo' missing in call to \(eval\))'
# Looks like you failed 1 test of 3.
t/configfile.t .......................... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
t/moose.t ............................... skipped: Moose and MooseX::Getopt required to test Moose usage
t/mouse.t ............................... ok   
t/release-changes_has_content.t ......... skipped: these tests are for release candidate testing
t/release-cpan-changes.t ................ skipped: these tests are for release candidate testing
t/release-dist-manifest.t ............... skipped: these tests are for release candidate testing
t/release-distmeta.t .................... skipped: these tests are for release candidate testing
t/release-kwalitee.t .................... skipped: these tests are for release candidate testing
t/release-localbrew-perl-latest-TEST.t .. skipped: these tests are for release candidate testing
t/release-meta-json.t ................... skipped: these tests are for release candidate testing
t/release-minimum-version.t ............. skipped: these tests are for release candidate testing
t/release-mojibake.t .................... skipped: these tests are for release candidate testing
t/release-no-tabs.t ..................... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ................ skipped: these tests are for release candidate testing
t/release-pod-linkcheck.t ............... skipped: these tests are for release candidate testing
t/release-pod-syntax.t .................. skipped: these tests are for release candidate testing
t/release-portability.t ................. skipped: these tests are for release candidate testing
t/release-synopsis.t .................... skipped: these tests are for release candidate testing
t/release-test-version.t ................ skipped: these tests are for release candidate testing
t/release-unused-vars.t ................. skipped: these tests are for release candidate testing

Test Summary Report
-------------------
t/basic.t                             (Wstat: 256 Tests: 12 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/configfile.t                        (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=26, Tests=45,  1 wallclock secs ( 0.05 usr  0.02 sys +  0.89 cusr  0.06 csys =  1.02 CPU)
Result: FAIL
Failed 2/26 test programs. 2/45 subtests failed.
Makefile:887: recipe for target 'test_dynamic' failed
make: *** [test_dynamic] Error 255
  MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
  /usr/bin/make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
  reports MJGARDNER/MooseX-App-Cmd-0.27.tar.gz
Running make install
  make test had returned bad status, won't install without force

@sschober

This comment has been minimized.

Show comment Hide comment
@sschober

sschober Jun 17, 2014

Nevermind: 61f086b fixes my problem.

Nevermind: 61f086b fixes my problem.

@brianwisti

This comment has been minimized.

Show comment Hide comment
@brianwisti

brianwisti Jul 19, 2014

Could 0.28 be made available on CPAN? I ran into this test failure while trying to install 0.27 as a dependency (with Perl 5.20.0, on OS X 10.9 and Ubuntu 14.04). Grabbing 0.28-TRIAL directly worked for me. Is there anything that keeps 0.28 from being officially released?

Could 0.28 be made available on CPAN? I ran into this test failure while trying to install 0.27 as a dependency (with Perl 5.20.0, on OS X 10.9 and Ubuntu 14.04). Grabbing 0.28-TRIAL directly worked for me. Is there anything that keeps 0.28 from being officially released?

@eserte

This comment has been minimized.

Show comment Hide comment
@eserte

eserte Aug 9, 2014

Comparing
http://matrix.cpantesters.org/?dist=MooseX-App-Cmd%200.27 and
http://matrix.cpantesters.org/?dist=MooseX-App-Cmd%200.28-TRIAL
shows that the recent TRIAL version is not perfect, but far better than 0.27, so making the TRIAL version into an official release would be good.

eserte commented Aug 9, 2014

Comparing
http://matrix.cpantesters.org/?dist=MooseX-App-Cmd%200.27 and
http://matrix.cpantesters.org/?dist=MooseX-App-Cmd%200.28-TRIAL
shows that the recent TRIAL version is not perfect, but far better than 0.27, so making the TRIAL version into an official release would be good.

@oalders

This comment has been minimized.

Show comment Hide comment
@oalders

oalders Aug 9, 2014

+1 This failure was preventing me from installing App::GitGot on Perl 5.14.2 Ubuntu 12.04.4. Installing the TRIAL release fixed it for me.

oalders commented Aug 9, 2014

+1 This failure was preventing me from installing App::GitGot on Perl 5.14.2 Ubuntu 12.04.4. Installing the TRIAL release fixed it for me.

@ediblenergy

This comment has been minimized.

Show comment Hide comment
@ediblenergy

ediblenergy Aug 30, 2014

Same as oalders, TRIAL release worked for me.

Same as oalders, TRIAL release worked for me.

@rjbs

This comment has been minimized.

Show comment Hide comment
@rjbs

rjbs Sep 19, 2014

:bump:

rjbs commented Sep 19, 2014

:bump:

@rjbs

This comment has been minimized.

Show comment Hide comment
@rjbs

rjbs Nov 14, 2014

Please make a release with this update. I would greatly appreciate it, as would many others.

rjbs commented Nov 14, 2014

Please make a release with this update. I would greatly appreciate it, as would many others.

@ediblenergy

This comment has been minimized.

Show comment Hide comment
@ediblenergy

ediblenergy Nov 14, 2014

@mjgardner if you want to give me comaint i can release it as well :) i'm https://metacpan.org/author/SKAUFMAN on CPAN.

@mjgardner if you want to give me comaint i can release it as well :) i'm https://metacpan.org/author/SKAUFMAN on CPAN.

@karenetheridge

This comment has been minimized.

Show comment Hide comment
@karenetheridge

karenetheridge Nov 14, 2014

We could also move this repo into the moose organization and turn it over to the cabal to manage.

We could also move this repo into the moose organization and turn it over to the cabal to manage.

@oalders

This comment has been minimized.

Show comment Hide comment
@oalders

oalders Nov 14, 2014

+1. This has bitten me more than once.

oalders commented Nov 14, 2014

+1. This has bitten me more than once.

@sschober

This comment has been minimized.

Show comment Hide comment
@sschober

sschober Nov 14, 2014

+1

+1

@jomo666

This comment has been minimized.

Show comment Hide comment
@jomo666

jomo666 Nov 19, 2014

The TRIAL works, please release.

jomo666 commented Nov 19, 2014

The TRIAL works, please release.

@shadowcat-mst

This comment has been minimized.

Show comment Hide comment
@shadowcat-mst

shadowcat-mst Nov 19, 2014

Can we drag this into the Moose org and give out co-maint to the usual suspects? That would remove the bottleneck and might make life easier

Can we drag this into the Moose org and give out co-maint to the usual suspects? That would remove the bottleneck and might make life easier

@karenetheridge

This comment has been minimized.

Show comment Hide comment
@karenetheridge

karenetheridge Jan 6, 2015

I have just uploaded version 0.29, which contains the same code as 0.28-TRIAL.

I have just uploaded version 0.29, which contains the same code as 0.28-TRIAL.

@oalders

This comment has been minimized.

Show comment Hide comment
@oalders

oalders Jan 6, 2015

\o/

oalders commented Jan 6, 2015

\o/

@karenetheridge

This comment has been minimized.

Show comment Hide comment
@karenetheridge

karenetheridge Jan 6, 2015

@mjgardner unfortunately while I have comaint on the MooseX:: bits I don't have them on the MouseX:: bits. Would you consider giving me comaint temporarily so we can get this release indexed, and then we can split the dists apart and you can have the MouseX part back? Right now, people aren't able to install this release. thanks!

@mjgardner unfortunately while I have comaint on the MooseX:: bits I don't have them on the MouseX:: bits. Would you consider giving me comaint temporarily so we can get this release indexed, and then we can split the dists apart and you can have the MouseX part back? Right now, people aren't able to install this release. thanks!

@mjgardner

This comment has been minimized.

Show comment Hide comment
@mjgardner

mjgardner Jan 7, 2015

Owner

On Jan 6, 2015, at 10:07 AM, Karen Etheridge notifications@github.com wrote:
@mjgardner https://github.com/mjgardner unfortunately while I have comaint on the MooseX:: bits I don't have them on the MouseX:: bits. Would you consider giving me comaint temporarily so we can get this release indexed, and then we can split the dists apart and you can have the MouseX part back? Right now, people aren't able to install this release. thanks!

Done.

Owner

mjgardner commented Jan 7, 2015

On Jan 6, 2015, at 10:07 AM, Karen Etheridge notifications@github.com wrote:
@mjgardner https://github.com/mjgardner unfortunately while I have comaint on the MooseX:: bits I don't have them on the MouseX:: bits. Would you consider giving me comaint temporarily so we can get this release indexed, and then we can split the dists apart and you can have the MouseX part back? Right now, people aren't able to install this release. thanks!

Done.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment