Skip to content
Permalink
Browse files

test_imapclient: Fix LoggerAdapter version check

The LoggerAdapter behavior change has been backported into Python 3.6.4.
Update the check to expect logger.log() call in 3.6.4+ rather than 3.7+.

Fixes #383.
  • Loading branch information...
mgorny committed Aug 10, 2019
1 parent 202398c commit 26fb9c9794ad0b2541320d71d5704fce5642a53c
Showing with 2 additions and 2 deletions.
  1. +2 −2 tests/test_imapclient.py
@@ -604,8 +604,8 @@ def test_redacted_password(self):
adapter = IMAPlibLoggerAdapter(logger_mock, dict())
if six.PY3:
adapter.info("""> b'ICHH1 LOGIN foo@bar.org "secret"'""")
if sys.version_info >= (3, 7):
# LoggerAdapter in Python 3.7+ calls logger.log()
if sys.version_info >= (3, 6, 4):
# LoggerAdapter in Python 3.6.4+ calls logger.log()
logger_mock.log.assert_called_once_with(
logging.INFO,
"> b'ICHH1 LOGIN **REDACTED**",

0 comments on commit 26fb9c9

Please sign in to comment.
You can’t perform that action at this time.