Switch branches/tags
themer-xcode-v2.0.4 themer-xcode-v2.0.3 themer-xcode-v2.0.2 themer-xcode-v2.0.1 themer-xcode-v2.0.0 themer-xcode-v1.0.0 themer-wallpaper-trianglify-v1.0.2 themer-wallpaper-trianglify-v1.0.1 themer-wallpaper-triangles-v2.0.5 themer-wallpaper-triangles-v2.0.4 themer-wallpaper-triangles-v2.0.3 themer-wallpaper-triangles-v2.0.2 themer-wallpaper-triangles-v2.0.1 themer-wallpaper-triangles-v2.0.0 themer-wallpaper-triangles-v1.0.1 themer-wallpaper-triangles-v1.0.0 themer-wallpaper-octagon-v3.0.1 themer-wallpaper-octagon-v3.0.0 themer-wallpaper-octagon-v2.0.3 themer-wallpaper-octagon-v2.0.2 themer-wallpaper-octagon-v2.0.1 themer-wallpaper-octagon-v2.0.0 themer-wallpaper-octagon-v1.0.4 themer-wallpaper-octagon-v1.0.3 themer-wallpaper-octagon-v1.0.2 themer-wallpaper-octagon-v1.0.1 themer-wallpaper-octagon-v1.0.0 themer-wallpaper-block-wave-v3.0.1 themer-wallpaper-block-wave-v3.0.0 themer-wallpaper-block-wave-v2.0.3 themer-wallpaper-block-wave-v2.0.2 themer-wallpaper-block-wave-v2.0.1 themer-wallpaper-block-wave-v2.0.0 themer-wallpaper-block-wave-v1.0.4 themer-wallpaper-block-wave-v1.0.3 themer-wallpaper-block-wave-v1.0.2 themer-wallpaper-block-wave-v1.0.1 themer-wallpaper-block-wave-v1.0.0 themer-vscode-v2.0.1 themer-vscode-v2.0.0 themer-vscode-v1.2.0 themer-vscode-v1.1.0 themer-vscode-v1.0.6 themer-vscode-v1.0.5 themer-vscode-v1.0.4 themer-vscode-v1.0.3 themer-vscode-v1.0.2 themer-vscode-v1.0.1 themer-vscode-v1.0.0 themer-vim-v3.0.1 themer-vim-v3.0.0 themer-vim-v2.2.9 themer-vim-v2.2.8 themer-vim-v2.2.7 themer-vim-v2.2.6 themer-vim-v2.2.5 themer-vim-v2.2.4 themer-vim-v2.2.3 themer-vim-v2.2.2 themer-vim-v2.2.1 themer-vim-v2.2.0 themer-vim-v2.1.0 themer-vim-v2.0.0 themer-vim-v1.0.0 themer-vim-lightline-v3.0.1 themer-vim-lightline-v3.0.0 themer-vim-lightline-v2.0.7 themer-vim-lightline-v2.0.6 themer-vim-lightline-v2.0.5 themer-vim-lightline-v2.0.4 themer-vim-lightline-v2.0.3 themer-vim-lightline-v2.0.2 themer-vim-lightline-v2.0.1 themer-vim-lightline-v2.0.0 themer-vim-lightline-v1.0.0 themer-v3.1.4 themer-v3.1.3 themer-v3.1.2 themer-v3.1.1 themer-v3.1.0 themer-v3.0.0 themer-v2.2.4 themer-v2.2.3 themer-v2.2.2 themer-v2.2.1 themer-v2.2.0 themer-v2.1.0 themer-v2.0.0 themer-v1.2.1 themer-v1.2.0 themer-v1.0.2 themer-v1.0.1 themer-v1.0.0 themer-terminal-v2.0.1 themer-terminal-v2.0.0 themer-terminal-v1.0.5 themer-terminal-v1.0.4 themer-terminal-v1.0.3 themer-terminal-v1.0.2 themer-terminal-v1.0.1
Nothing to show
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
..
Failed to load latest commit information.
lib
.gitignore
.yarnrc
README.md
package.json

README.md

themer-hyper

A Hyper.app plugin generator for themer.

Installation & usage

Install this module wherever you have themer installed:

npm install themer-hyper

Then pass themer-hyper as a -t (--template) arg to themer:

themer -c my-colors.js -t themer-hyper -o gen

Output

themer-hyper will generate a themer-hyper-dark/ or themer-hyper-light/ directory (or both), depending on which color set you passed to themer, which will contain the files for a Hyper theme plugin package.

To install your generated plugin, first symlink the outputted package directory to the Hyper local plugins directory:

ln -s <full path to themer output directory>/themer-hyper/themer-hyper-dark ~/.hyper_plugins/local/

Finally, edit ~/.hyper.js and add the package to the localPlugins array:

...
localPlugins: [
  'themer-hyper-dark'
],
...