Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update requirements #104

Closed
sampsyo opened this issue Jul 13, 2014 · 3 comments
Closed

Update requirements #104

sampsyo opened this issue Jul 13, 2014 · 3 comments

Comments

@sampsyo
Copy link
Contributor

@sampsyo sampsyo commented Jul 13, 2014

While working with Markdown extensions (c.f. #74), I noticed that mkdocs' setup.py has its dependencies pinned to specific patch versions:

install_requires = [
    'Jinja2==2.7.1',
    'Markdown==2.3.1',
    'PyYAML==3.10',
    'watchdog==0.7.0',
    'ghp-import==0.4.1'
]

Since these dependencies are slightly out of date (e.g., Jinja2 is at 2.7.3 and Markdown is at 2.4.1), it's hard to use mkdocs on a system with other software. Perhaps it's a shame that Python doesn't have npm-like dependency management, but that's the way it is—you'll get a setuptools when trying to run mkdocs error if any other package upgrades Jinja to a bugfix release.

How would the developers feel about loosening these version requirements? An idiomatic approach is to just use >=.

@d0ugal
Copy link
Member

@d0ugal d0ugal commented Jul 28, 2014

+1 to loosening the versions. I have had a quick look and I can't see anything that would require those pinned versions.

d0ugal added a commit to d0ugal/mkdocs that referenced this issue Aug 22, 2014
@sampsyo
Copy link
Contributor Author

@sampsyo sampsyo commented Oct 17, 2014

I don't mean this as a no-op "bump" comment, but I want to note that this is getting increasingly inconvenient. Of the 5 dependencies, 4 are now out of date (only ghp-import is still current). This means that, if you have anything else installed that uses the (quite popular) PyYAML, Markdown, Jinja2, or Watchdog libraries, you likely have a more recent version and Mkdocs will refuse to run.

Would a (really simple) new pull request be helpful here?

d0ugal added a commit to d0ugal/mkdocs that referenced this issue Oct 17, 2014
@d0ugal
Copy link
Member

@d0ugal d0ugal commented Oct 17, 2014

As it happens I ran into this issue today too. I had to downgrade a project from Jinja2 from 2.7.3 to 2.7.1 to add MkDocs. I rebased and re-opened #130 - can you review that?

d0ugal added a commit to d0ugal/mkdocs that referenced this issue Oct 17, 2014
d0ugal added a commit to d0ugal/mkdocs that referenced this issue Oct 18, 2014
@d0ugal d0ugal closed this in #130 Oct 22, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

2 participants
You can’t perform that action at this time.