Skip to content

Installing

Matt Keeter edited this page Feb 5, 2014 · 10 revisions

kokopelli has been tested on Mac OS X (10.6+) and Ubuntu 12.04 LTS.

It uses the following libraries and packages:

Package Comments
Python 2.7 The main language of kokopelli
wxPython 2.9 UI toolkit
PyOpenGL Rendering tools
NumPy Fast array manipulation
CMake Cross-platform build file generation
libpng Image I/O

With the dependancies installed, running make in the top-level directory will compile the C library.
With the C library compiled, ./kokopelli will run the application.

Alternatively, make install will install a local copy. kokopelli and the koko folder will be copied into /usr/local/bin, and libfab.dylib/libfab.so will be copied to /usr/local/lib.

Ubuntu

Most of the packages are available from your friendly neighborhood package manager.

sudo apt-get install python python-dev python-pip gcc g++ libpng12-dev make bash cmake

The required Python libraries are available through pip.

sudo pip install numpy PyOpenGL PyOpenGL_accelerate

Lastly, a newer version of wxPython is required than is available from the Ubuntu package manager. The install_wxpython3.0.sh script in the util folder will automatically download, patch, compile, and install it.

Mac

If you want to try out kokopelli without setting up a development environment, then download the app.
Otherwise, read on.

A C compiler is required to build the geometry library. XCode or the Command-line Tools for XCode both come with a full set of development tools (though if you install XCode, you may have to set up the command-line tools separately).

Python may already be on your system: run python --version to confirm that it is 2.7.
NumPy and PyOpenGL can both be installed with pip:

sudo pip install PyOpenGL PyOpenGL_accelerate numpy

(if pip is not found, install it with sudo easy_install pip)

libpng should already be installed on your system.

CMake can be downloaded from their website or installed through Homebrew.

wxPython can be downloaded from their website. The 2.9-cocoa version is required.

You can’t perform that action at this time.