Skip to content
Browse files

use rails 2.3.8 for integration-test

  • Loading branch information...
1 parent 989bdf5 commit 4315c5a98631b97579bbae62dac34d2c27a5c446 @mkristian committed
Showing with 2 additions and 2 deletions.
  1. +1 −1 Rakefile
  2. +1 −1 lib/datamapper4rails/integration_test.rb
View
2 Rakefile
@@ -39,7 +39,7 @@ Spec::Rake::SpecTask.new(:spec) do |t|
end
desc 'generate rails using all generators and run the specs'
-task :integration_tests => [:spec, :install] do
+task :"integration-test" => [:spec, :install] do
require 'datamapper4rails/integration_test'
Datamapper4Rails::IntegrationTest.new do |t|
t.generate "datamapper_model role name:string"
View
2 lib/datamapper4rails/integration_test.rb
@@ -22,7 +22,7 @@ def generate(*args)
def execute
FileUtils.rm_rf(@directory)
- run("-S rails -fm #{rails_template} #{directory}")
+ run("-S rails _2.3.8_ -fm #{rails_template} #{directory}")
FileUtils.cd(@directory) do
@generator_args.each do |arg|
run("script/generate #{arg}")

0 comments on commit 4315c5a

Please sign in to comment.
Something went wrong with that request. Please try again.