Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

new versions

  • Loading branch information...
commit cab55d4983f96fc29b7a1ca840f656677510436b 1 parent c20386d
@mkristian authored
Showing with 326 additions and 319 deletions.
  1. +1 −1  Gemfile
  2. +5 −5 Gemfile.lock
  3. +1 −1  Mavenfile
  4. +319 −312 pom.xml
View
2  Gemfile
@@ -40,4 +40,4 @@ group :development, :test do
gem 'resty-generators', '~> 0.7.3', :require => false#, :path => '../../gwt/rails-resty-gwt/resty-generators'
end
-gem 'copyright-header', '~> 1.0.7', :group => :development
+gem 'copyright-header', '~> 1.0.7', :group => :development, :platform => :mri
View
10 Gemfile.lock
@@ -24,7 +24,7 @@ GEM
i18n (= 0.6.1)
multi_json (~> 1.0)
arel (3.0.2)
- backports (3.3.1)
+ backports (3.3.2)
bcrypt-ruby (3.0.1)
bcrypt-ruby (3.0.1-java)
builder (3.0.4)
@@ -42,12 +42,12 @@ GEM
escape_utils (~> 0.3.1)
mime-types (~> 1.19)
pygments.rb (~> 0.4.2)
- hike (1.2.2)
+ hike (1.2.3)
i18n (0.6.1)
- ixtlan-audit (0.4.1)
+ ixtlan-audit (0.4.2)
slf4r (~> 0.4.2)
ixtlan-babel (0.3.5)
- ixtlan-error-handler (0.4.1)
+ ixtlan-error-handler (0.4.2)
slf4r (~> 0.4.2)
ixtlan-generators (0.1.7)
ixtlan-gettext (0.1.3)
@@ -69,7 +69,7 @@ GEM
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.23)
- multi_json (1.7.6)
+ multi_json (1.7.7)
pg (0.15.1)
polyglot (0.3.3)
pony (1.4.1)
View
2  Mavenfile
@@ -61,7 +61,7 @@ end
# lock down versions
properties['gwt.version'] = '2.5.1-rc1'
-properties['jruby.version'] = '1.7.3'
+properties['jruby.version'] = '1.7.4'
properties['jruby.plugins.version'] = '0.29.4'
# jetty version to run it in standalone jetty via jetty-run
properties['jetty.version'] = '8.1.9.v20130131'
View
631 pom.xml
@@ -185,6 +185,11 @@
</dependency>
<dependency>
<groupId>rubygems</groupId>
+ <artifactId>ixtlan-user-management</artifactId>
+ <type>gem</type>
+ </dependency>
+ <dependency>
+ <groupId>rubygems</groupId>
<artifactId>ixtlan-remote</artifactId>
<type>gem</type>
</dependency>
@@ -249,6 +254,31 @@
<type>gem</type>
</dependency>
<dependency>
+ <groupId>org.jruby.rack</groupId>
+ <artifactId>jruby-rack</artifactId>
+ <version>1.1.13.1</version>
+ <type>jar</type>
+ <exclusions>
+ <exclusion>
+ <groupId>org.jruby</groupId>
+ <artifactId>jruby-complete</artifactId>
+ </exclusion>
+ </exclusions>
+ </dependency>
+ <dependency>
+ <groupId>org.jruby</groupId>
+ <artifactId>jruby-core</artifactId>
+ <version>${jruby.version}</version>
+ <type>jar</type>
+ </dependency>
+ <dependency>
+ <groupId>com.google.gwt</groupId>
+ <artifactId>gwt-user</artifactId>
+ <version>${gwt.version}</version>
+ <type>jar</type>
+ <scope>provided</scope>
+ </dependency>
+ <dependency>
<groupId>de.mkristian.gwt</groupId>
<artifactId>rails-gwt</artifactId>
<version>0.8.0-SNAPSHOT</version>
@@ -270,16 +300,9 @@
<scope>provided</scope>
</dependency>
<dependency>
- <groupId>com.google.gwt</groupId>
- <artifactId>gwt-user</artifactId>
- <version>2.4.0</version>
- <type>jar</type>
- <scope>provided</scope>
- </dependency>
- <dependency>
<groupId>com.google.gwt.inject</groupId>
<artifactId>gin</artifactId>
- <version>1.5.0</version>
+ <version>2.0.0</version>
<type>jar</type>
<scope>provided</scope>
</dependency>
@@ -299,53 +322,41 @@
<classifier>sources</classifier>
</dependency>
<dependency>
- <groupId>org.jruby.rack</groupId>
- <artifactId>jruby-rack</artifactId>
- <version>1.1.7</version>
- <type>jar</type>
- </dependency>
- <dependency>
<groupId>rubygems</groupId>
<artifactId>bundler</artifactId>
<type>gem</type>
</dependency>
- <dependency>
- <groupId>org.jruby</groupId>
- <artifactId>jruby-complete</artifactId>
- <version>${jruby.version}</version>
- <type>jar</type>
- </dependency>
</dependencies>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>rubygems</groupId>
<artifactId>actionpack</artifactId>
- <version>3.2.12</version>
+ <version>3.2.13</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>activemodel</artifactId>
- <version>3.2.12</version>
+ <version>3.2.13</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>activesupport</artifactId>
- <version>3.2.12</version>
+ <version>3.2.13</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>i18n</artifactId>
- <version>0.6.2</version>
+ <version>0.6.1</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>multi_json</artifactId>
- <version>1.6.1</version>
+ <version>1.7.7</version>
<type>gem</type>
</dependency>
<dependency>
@@ -393,19 +404,19 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>hike</artifactId>
- <version>1.2.1</version>
+ <version>1.2.2</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>tilt</artifactId>
- <version>1.3.3</version>
+ <version>1.4.1</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>activerecord</artifactId>
- <version>3.2.12</version>
+ <version>3.2.13</version>
<type>gem</type>
</dependency>
<dependency>
@@ -417,19 +428,19 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>tzinfo</artifactId>
- <version>0.3.35</version>
+ <version>0.3.37</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>activerecord-jdbc-adapter</artifactId>
- <version>1.2.7</version>
+ <version>1.2.9</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>backports</artifactId>
- <version>2.6.7</version>
+ <version>3.3.1</version>
<type>gem</type>
</dependency>
<dependency>
@@ -440,62 +451,50 @@
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>capybara</artifactId>
- <version>2.0.2</version>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>mime-types</artifactId>
- <version>1.21</version>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>nokogiri</artifactId>
- <version>1.5.6</version>
+ <artifactId>charlock_holmes</artifactId>
+ <version>0.6.9.4</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>selenium-webdriver</artifactId>
- <version>2.30.0</version>
+ <artifactId>copyright-header</artifactId>
+ <version>1.0.10</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>childprocess</artifactId>
- <version>0.3.8</version>
+ <artifactId>github-linguist</artifactId>
+ <version>2.6.7</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>ffi</artifactId>
- <version>1.4.0</version>
+ <artifactId>escape_utils</artifactId>
+ <version>0.3.2</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>rubyzip</artifactId>
- <version>0.9.9</version>
+ <artifactId>mime-types</artifactId>
+ <version>1.23</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>websocket</artifactId>
- <version>1.0.7</version>
+ <artifactId>pygments.rb</artifactId>
+ <version>0.4.2</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>xpath</artifactId>
- <version>1.0.0</version>
+ <artifactId>posix-spawn</artifactId>
+ <version>0.3.6</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>copyright-header</artifactId>
- <version>1.0.7</version>
+ <artifactId>yajl-ruby</artifactId>
+ <version>1.1.0</version>
<type>gem</type>
</dependency>
<dependency>
@@ -537,7 +536,7 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>ixtlan-babel</artifactId>
- <version>0.3.2</version>
+ <version>0.3.5</version>
<type>gem</type>
</dependency>
<dependency>
@@ -579,13 +578,13 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>virtus</artifactId>
- <version>0.5.4</version>
+ <version>0.5.5</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>ixtlan-optimistic</artifactId>
- <version>0.2.2</version>
+ <version>0.2.3</version>
<type>gem</type>
</dependency>
<dependency>
@@ -596,6 +595,12 @@
</dependency>
<dependency>
<groupId>rubygems</groupId>
+ <artifactId>ixtlan-user-management</artifactId>
+ <version>0.1.2</version>
+ <type>gem</type>
+ </dependency>
+ <dependency>
+ <groupId>rubygems</groupId>
<artifactId>jdbc-sqlite3</artifactId>
<version>3.7.2.1</version>
<type>gem</type>
@@ -603,19 +608,19 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>json</artifactId>
- <version>1.7.7</version>
+ <version>1.8.0</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>mail</artifactId>
- <version>2.5.3</version>
+ <version>2.5.4</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>treetop</artifactId>
- <version>1.4.12</version>
+ <version>1.4.14</version>
<type>gem</type>
</dependency>
<dependency>
@@ -627,13 +632,13 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>pg</artifactId>
- <version>0.14.1</version>
+ <version>0.15.1</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>pony</artifactId>
- <version>1.4</version>
+ <version>1.4.1</version>
<type>gem</type>
</dependency>
<dependency>
@@ -645,13 +650,13 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>railties</artifactId>
- <version>3.2.12</version>
+ <version>3.2.13</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
<artifactId>rake</artifactId>
- <version>10.0.3</version>
+ <version>10.0.4</version>
<type>gem</type>
</dependency>
<dependency>
@@ -663,7 +668,7 @@
<dependency>
<groupId>rubygems</groupId>
<artifactId>thor</artifactId>
- <version>0.17.0</version>
+ <version>0.18.1</version>
<type>gem</type>
</dependency>
<dependency>
@@ -714,60 +719,16 @@
<gem.home>${project.build.directory}/rubygems</gem.home>
<gem.includeRubygemsInTestResources>false</gem.includeRubygemsInTestResources>
<gem.path>${project.build.directory}/rubygems</gem.path>
- <jruby-plugins-version>0.30.0</jruby-plugins-version>
- <jruby.plugins.version>0.29.0</jruby.plugins.version>
- <jruby.version>1.7.2</jruby.version>
+ <gwt.version>2.5.1-rc1</gwt.version>
+ <jetty.version>8.1.9.v20130131</jetty.version>
+ <jruby.plugins.version>0.29.4</jruby.plugins.version>
+ <jruby.version>1.7.3</jruby.version>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<rails.env>development</rails.env>
</properties>
<build>
<plugins>
<plugin>
- <artifactId>maven-compiler-plugin</artifactId>
- <version>3.0</version>
- <configuration>
- <source>1.6</source>
- <target>1.6</target>
- </configuration>
- </plugin>
- <plugin>
- <artifactId>maven-war-plugin</artifactId>
- <version>2.2</version>
- <configuration>
- <webResources>
- <resource>
- <directory>public</directory>
- </resource>
- <resource>
- <directory>.</directory>
- <includes>
- <include>app/**</include>
- <include>config/**</include>
- <include>lib/**</include>
- <include>vendor/**</include>
- <include>Gemfile</include>
- </includes>
- <targetPath>WEB-INF</targetPath>
- </resource>
- <resource>
- <directory>${gem.path}</directory>
- <includes>
- <include>gems/**</include>
- <include>specifications/**</include>
- </includes>
- <targetPath>WEB-INF/gems</targetPath>
- </resource>
- <resource>
- <directory>${gem.path}-bundler-maven-plugin</directory>
- <includes>
- <include>specifications/**</include>
- </includes>
- <targetPath>WEB-INF/gems</targetPath>
- </resource>
- </webResources>
- </configuration>
- </plugin>
- <plugin>
<groupId>de.saumya.mojo</groupId>
<artifactId>bundler-maven-plugin</artifactId>
<version>${jruby.plugins.version}</version>
@@ -811,115 +772,163 @@
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>capybara</artifactId>
- <version>2.0.2</version>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>nokogiri</artifactId>
- <version>1.5.6</version>
+ <artifactId>resty-generators</artifactId>
+ <version>[0.7.3,0.7.99999]</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>selenium-webdriver</artifactId>
- <version>2.30.0</version>
+ <artifactId>ixtlan-generators</artifactId>
+ <version>0.1.7</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>childprocess</artifactId>
- <version>0.3.8</version>
+ <artifactId>copyright-header</artifactId>
+ <version>[1.0.7,1.0.99999]</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>ffi</artifactId>
- <version>1.4.0</version>
+ <artifactId>github-linguist</artifactId>
+ <version>2.6.7</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>rubyzip</artifactId>
- <version>0.9.9</version>
+ <artifactId>charlock_holmes</artifactId>
+ <version>0.6.9.4</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>websocket</artifactId>
- <version>1.0.7</version>
+ <artifactId>escape_utils</artifactId>
+ <version>0.3.2</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>xpath</artifactId>
- <version>1.0.0</version>
+ <artifactId>pygments.rb</artifactId>
+ <version>0.4.2</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>resty-generators</artifactId>
- <version>[0.7.3,0.7.99999]</version>
+ <artifactId>posix-spawn</artifactId>
+ <version>0.3.6</version>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>ixtlan-generators</artifactId>
- <version>0.1.7</version>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>copyright-header</artifactId>
- <version>[1.0.7,1.0.99999]</version>
+ <artifactId>yajl-ruby</artifactId>
+ <version>1.1.0</version>
<type>gem</type>
</dependency>
</dependencies>
</plugin>
<plugin>
- <groupId>de.saumya.mojo</groupId>
- <artifactId>rails3-maven-plugin</artifactId>
- <version>${jruby.plugins.version}</version>
- <executions>
- <execution>
- <id>in_phase_initialize</id>
- <phase>initialize</phase>
- <goals>
- <goal>pom</goal>
- </goals>
- <configuration>
- <force>true</force>
- </configuration>
- </execution>
- <execution>
- <id>in_phase_validate</id>
- <phase>validate</phase>
- <goals>
- <goal>initialize</goal>
- </goals>
- </execution>
- </executions>
+ <artifactId>maven-compiler-plugin</artifactId>
+ <version>3.0</version>
+ <configuration>
+ <source>1.6</source>
+ <target>1.6</target>
+ </configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>gwt-maven-plugin</artifactId>
- <version>2.4.0</version>
+ <version>${gwt.version}</version>
<configuration>
+ <draftCompile>true</draftCompile>
<extraJvmArgs>-Xmx512m</extraJvmArgs>
<gen>${project.build.directory}/generated</gen>
<hostedWebapp>${basedir}/public</hostedWebapp>
+ <includes>**/de.mkristian.ixtlan.users.Users_NAMEGWTTestSuite.java</includes>
<inplace>true</inplace>
<logLevel>INFO</logLevel>
+ <module>de.mkristian.ixtlan.users.UsersDevelopment</module>
<runTarget>Users.html</runTarget>
+ <style>DETAILED</style>
<treeLogger>true</treeLogger>
<warSourceDirectory>${basedir}/public</warSourceDirectory>
<webXml>${basedir}/public/WEB-INF/web.xml</webXml>
<webappDirectory>${basedir}/public</webappDirectory>
</configuration>
<executions>
+ <execution>
+ <id>in_phase_integration_test</id>
+ <phase>integration-test</phase>
+ <goals>
+ <goal>test</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>in_phase_compile</id>
+ <phase>compile</phase>
+ <goals>
+ <goal>compile</goal>
+ </goals>
+ </execution>
+ <execution>
+ <id>in_phase_clean</id>
+ <phase>clean</phase>
+ <goals>
+ <goal>clean</goal>
+ </goals>
+ </execution>
+ </executions>
+ </plugin>
+ <plugin>
+ <groupId>de.saumya.mojo</groupId>
+ <artifactId>rails3-maven-plugin</artifactId>
+ <version>${jruby.plugins.version}</version>
+ <executions>
+ <execution>
+ <id>in_phase_validate</id>
+ <phase>validate</phase>
+ <goals>
+ <goal>initialize</goal>
+ </goals>
+ </execution>
</executions>
</plugin>
+ <plugin>
+ <artifactId>maven-war-plugin</artifactId>
+ <version>2.2</version>
+ <configuration>
+ <webResources>
+ <resource>
+ <directory>public</directory>
+ </resource>
+ <resource>
+ <directory>.</directory>
+ <includes>
+ <include>app/**</include>
+ <include>config/**</include>
+ <include>lib/**</include>
+ <include>vendor/**</include>
+ <include>Gemfile</include>
+ </includes>
+ <targetPath>WEB-INF</targetPath>
+ </resource>
+ <resource>
+ <directory>${gem.path}</directory>
+ <includes>
+ <include>gems/**</include>
+ <include>specifications/**</include>
+ </includes>
+ <targetPath>WEB-INF/gems</targetPath>
+ </resource>
+ <resource>
+ <directory>${gem.path}-bundler-maven-plugin</directory>
+ <includes>
+ <include>specifications/**</include>
+ </includes>
+ <targetPath>WEB-INF/gems</targetPath>
+ </resource>
+ </webResources>
+ </configuration>
+ </plugin>
</plugins>
<pluginManagement>
<plugins>
@@ -943,20 +952,6 @@
<versionRange>[0,)</versionRange>
</pluginExecutionFilter>
</pluginExecution>
- <pluginExecution>
- <action>
- <ignore></ignore>
- </action>
- <pluginExecutionFilter>
- <artifactId>rails3-maven-plugin</artifactId>
- <goals>
- <goal>initialize</goal>
- <goal>pom</goal>
- </goals>
- <groupId>de.saumya.mojo</groupId>
- <versionRange>[0,)</versionRange>
- </pluginExecutionFilter>
- </pluginExecution>
</pluginExecutions>
</lifecycleMappingMetadata>
</configuration>
@@ -966,12 +961,6 @@
</build>
<profiles>
<profile>
- <id>assets</id>
- <activation>
- <activeByDefault>true</activeByDefault>
- </activation>
- </profile>
- <profile>
<id>development</id>
<activation>
<activeByDefault>true</activeByDefault>
@@ -1004,42 +993,55 @@
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>capybara</artifactId>
+ <artifactId>resty-generators</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>nokogiri</artifactId>
+ <artifactId>ixtlan-generators</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>selenium-webdriver</artifactId>
+ <artifactId>copyright-header</artifactId>
+ <version>[1.0.7,1.0.99999]</version>
<type>gem</type>
</dependency>
+ </dependencies>
+ </profile>
+ <profile>
+ <id>test</id>
+ <activation>
+ <activeByDefault>true</activeByDefault>
+ <property>
+ <name>rails.env</name>
+ <value>test</value>
+ </property>
+ </activation>
+ <dependencies>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>childprocess</artifactId>
+ <artifactId>rspec-rails</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>ffi</artifactId>
+ <artifactId>rspec-core</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>rubyzip</artifactId>
+ <artifactId>rspec-expectations</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>websocket</artifactId>
+ <artifactId>diff-lcs</artifactId>
<type>gem</type>
</dependency>
<dependency>
<groupId>rubygems</groupId>
- <artifactId>xpath</artifactId>
+ <artifactId>rspec-mocks</artifactId>
<type>gem</type>
</dependency>
<dependency>
@@ -1052,24 +1054,33 @@
<artifactId>ixtlan-generators</artifactId>
<type>gem</type>
</dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>copyright-header</artifactId>
- <version>[1.0.7,1.0.99999]</version>
- <type>gem</type>
- </dependency>
</dependencies>
+ </profile>
+ <profile>
+ <id>production</id>
+ <activation>
+ <property>
+ <name>rails.env</name>
+ <value>production</value>
+ </property>
+ </activation>
+ <properties>
+ <gem.home>${project.build.directory}/rubygems-production</gem.home>
+ <gem.path>${project.build.directory}/rubygems-production</gem.path>
+ </properties>
<build>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>gwt-maven-plugin</artifactId>
- <version>2.4.0</version>
+ <version>${gwt.version}</version>
<configuration>
- <draftCompile>true</draftCompile>
- <includes>**/UsersGWTTestSuite.java</includes>
- <module>de.mkristian.ixtlan.users.UsersDevelopment</module>
- <style>DETAILED</style>
+ <disableCastChecking>true</disableCastChecking>
+ <disableClassMetadata>true</disableClassMetadata>
+ <draftCompile>false</draftCompile>
+ <module>de.mkristian.ixtlan.users.Users</module>
+ <optimizationLevel>9</optimizationLevel>
+ <style>OBF</style>
</configuration>
</plugin>
</plugins>
@@ -1087,6 +1098,7 @@
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>gwt-maven-plugin</artifactId>
+ <version>${gwt.version}</version>
<configuration>
<extraJvmArgs>-d32 -XstartOnFirstThread -Xmx512m</extraJvmArgs>
</configuration>
@@ -1095,121 +1107,116 @@
</build>
</profile>
<profile>
- <id>production</id>
+ <id>assets</id>
<activation>
- <property>
- <name>rails.env</name>
- <value>production</value>
- </property>
+ <activeByDefault>true</activeByDefault>
</activation>
- <properties>
- <gem.home>${project.build.directory}/rubygems-production</gem.home>
- <gem.path>${project.build.directory}/rubygems-production</gem.path>
- </properties>
+ </profile>
+ <profile>
+ <id>war</id>
<build>
<plugins>
<plugin>
- <groupId>org.codehaus.mojo</groupId>
- <artifactId>gwt-maven-plugin</artifactId>
- <version>2.4.0</version>
- <configuration>
- <disableCastChecking>true</disableCastChecking>
- <disableClassMetadata>true</disableClassMetadata>
- <draftCompile>false</draftCompile>
- <module>de.mkristian.ixtlan.users.Users</module>
- <optimizationLevel>9</optimizationLevel>
- <style>OBF</style>
- </configuration>
+ <groupId>org.mortbay.jetty</groupId>
+ <artifactId>jetty-maven-plugin</artifactId>
+ <version>${jetty.version}</version>
</plugin>
</plugins>
</build>
</profile>
<profile>
- <id>test</id>
+ <id>run</id>
<activation>
<activeByDefault>true</activeByDefault>
- <property>
- <name>rails.env</name>
- <value>test</value>
- </property>
</activation>
- <dependencies>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>rspec-rails</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>rspec-core</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>rspec-expectations</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>diff-lcs</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>rspec-mocks</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>capybara</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>nokogiri</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>selenium-webdriver</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>childprocess</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>ffi</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>rubyzip</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>websocket</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>xpath</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>resty-generators</artifactId>
- <type>gem</type>
- </dependency>
- <dependency>
- <groupId>rubygems</groupId>
- <artifactId>ixtlan-generators</artifactId>
- <type>gem</type>
- </dependency>
- </dependencies>
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.mortbay.jetty</groupId>
+ <artifactId>jetty-maven-plugin</artifactId>
+ <version>${jetty.version}</version>
+ <configuration>
+ <connectors>
+ <connector implementation="org.eclipse.jetty.server.nio.SelectChannelConnector">
+ <port>8080</port>
+ </connector>
+ <connector implementation="org.eclipse.jetty.server.ssl.SslSelectChannelConnector">
+ <port>8443</port>
+ <keystore>${project.basedir}/src/test/resources/server.keystore</keystore>
+ <keyPassword>123456</keyPassword>
+ <password>123456</password>
+ </connector>
+ </connectors>
+ <systemProperties>
+ <systemProperty>
+ <name>jbundle.skip</name>
+ <value>true</value>
+ </systemProperty>
+ </systemProperties>
+ <webAppConfig>
+ <overrideDescriptor>${project.build.directory}/jetty/override-${rails.env}-web.xml</overrideDescriptor>
+ </webAppConfig>
+ </configuration>
+ </plugin>
+ </plugins>
+ </build>
+ </profile>
+ <profile>
+ <id>warshell</id>
+ <pluginRepositories>
+ <pluginRepository>
+ <id>kos</id>
+ <url>http://opensource.kantega.no/nexus/content/groups/public/</url>
+ </pluginRepository>
+ </pluginRepositories>
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.simplericity.jettyconsole</groupId>
+ <artifactId>jetty-console-maven-plugin</artifactId>
+ <version>1.42</version>
+ <executions>
+ <execution>
+ <goals>
+ <goal>createconsole</goal>
+ </goals>
+ <configuration>
+ <!--
+ see http://simplericity.com/2009/11/10/1257880778509.html for more info
+ -->
+ <!--
+ <backgroundImage>${basedir}/src/main/jettyconsole/puffin.jpg</backgroundImage>
+ <additionalDependencies>
+ <additionalDependency>
+ <artifactId>jetty-console-winsrv-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-requestlog-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-log4j-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-jettyxml-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-ajp-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-gzip-plugin</artifactId>
+ </additionalDependency>
+ <additionalDependency>
+ <artifactId>jetty-console-startstop-plugin</artifactId>
+ </additionalDependency>
+ </additionalDependencies>
+
+ -->
+ </configuration>
+ </execution>
+ </executions>
+ </plugin>
+ </plugins>
+ </build>
</profile>
</profiles>
</project>
Please sign in to comment.
Something went wrong with that request. Please try again.