Permalink
Browse files

get versions uptodate

  • Loading branch information...
1 parent bb1227f commit 8ff9dd3c944063dfd8f9590dc18ad9f559574c35 @mkristian committed Jan 23, 2013
Showing with 133 additions and 183 deletions.
  1. +1 −4 Gemfile
  2. +7 −3 Mavenfile
  3. +2 −0 jbundler.gemspec
  4. +123 −176 pom.xml
View
@@ -1,7 +1,4 @@
source :rubygems
gemspec
-group :test do
- gem 'minitest', '~> 4.3'
- gem 'cucumber', '~> 1.1.9'
-end
+gem 'jruby-openssl', '0.8.2', :platform => 'jruby'
View
@@ -22,6 +22,8 @@ properties['jruby.versions'] = ['1.5.6','1.6.8','1.7.2'].join(',')
# overwrite via cli -Djruby.use18and19=false
properties['jruby.18and19'] = true
+properties['jruby.plugins.version'] = '0.29.2'
+
plugin(:minitest) do |m|
m.execute_goal(:spec)
end
@@ -34,9 +36,11 @@ end
execute_in_phase( :initialize ) do
pom = File.read( 'pom.xml' )
- dot_pom = File.read( '.pom.xml' )
- if pom != dot_pom
- File.open( 'pom.xml', 'w' ) { |f| f.puts dot_pom }
+ if File.exists? '.pom.xml'
+ dot_pom = File.read( '.pom.xml' )
+ if pom != dot_pom
+ File.open( 'pom.xml', 'w' ) { |f| f.puts dot_pom }
+ end
end
end
View
@@ -23,5 +23,7 @@ END
s.add_runtime_dependency "ruby-maven", "~> 3.0.4"
s.add_development_dependency "rake", "~> 10.0.3"
s.add_development_dependency "thor", "< 0.16.0", "> 0.14.0"
+ s.add_development_dependency "cucumber", "~> 1.1.9"
+ s.add_development_dependency "minitest", "~> 4.3"
end
Oops, something went wrong.

0 comments on commit 8ff9dd3

Please sign in to comment.