Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Compare: rubyjams (draft)

Showing with 4 additions and 4 deletions.
  1. +4 −4 rubyjams-(draft).md
View
8 rubyjams-(draft).md
@@ -22,7 +22,7 @@ since all jams are maven jar artifacts the configurations allow to use most of t
in case the `any_gem` depends on a jam it will install jar and its transitive dependencies.
-### installing gems with jams dependencies
+### installing jams directly
gem install any_group_id:any_artifact_id --version my_version
@@ -32,15 +32,15 @@ this will install any_group_id:any_artifact_id from maven central unless t is al
### using jams
+ require 'rubygems'
require 'rubyjams'
-that will also require 'rubygems'.
+whenever require 'something' activates a new gem then all its dependent jams will be added to the jruby classloader. whenever there is a version conflict with a already loaded jams (or jar) then an error gets raised.
-load a jam which is:
+load a jam directly through:
jam 'org.apache.solr:solr-core'
-whenever require 'something' activates a new gem then all its dependent jams will be added to the jruby classloader. whenever there is a version conflict with a already loaded jams (or jar) then an error gets raised.
### declaring jams dependencies
Something went wrong with that request. Please try again.