Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 38 lines (33 sloc) 1.527 kB
0f282c2 @mkristian first import
authored
1 require 'fileutils'
408ea41 @mkristian fix for ruby-1.9.x load path
authored
2 require File.expand_path('lib/ruby/maven/ruby/version.rb')
0f282c2 @mkristian first import
authored
3 Gem::Specification.new do |s|
4 s.name = %q{ruby-maven}
838591b @mkristian refactored ruby-maven and split into three files
authored
5 s.version = Maven::Ruby::VERSION
68635f0 @mkristian new project setup - the ruby way
authored
6
0f282c2 @mkristian first import
authored
7 s.authors = ["mkristian"]
04b606f @mkristian moved gwt and jetty-run to new gems
authored
8 s.description = %q{maven support for rubygems based on maven 3.0. it allows to use xyz.gemspec file as pom file or the usual pom.xml files. with a rails3 application with a Gemfile (suitable for jruby). you need java installed or jruby but it will run with MRI (without installed jruby) since the maven will take care of the jruby to use.}
0f282c2 @mkristian first import
authored
9 s.email = ["m.kristian@web.de"]
10 s.extra_rdoc_files = ["NOTICE.txt", "LICENSE.txt", "README.txt"]
11
12 s.files = Dir.glob("*.txt") +
73093a9 @mkristian polishing up. added gwt command
authored
13 Dir.glob("bin/mvn*") +
0f282c2 @mkristian first import
authored
14 Dir.glob("bin/rmvn") +
15 Dir.glob("bin/m2.conf") +
16 Dir.glob("boot/*") +
17 Dir.glob("conf/*") +
73093a9 @mkristian polishing up. added gwt command
authored
18 Dir.glob("lib/*") +
19 Dir.glob("lib/ext/*") +
20 Dir.glob("lib/ruby/ruby_maven.rb") +
306b61e @mkristian get cucumber support and little fixes
authored
21 Dir.glob("lib/ruby/ruby-maven.rb") +
73093a9 @mkristian polishing up. added gwt command
authored
22 Dir.glob("lib/ruby/maven/**/*")
0f282c2 @mkristian first import
authored
23 s.bindir = "bin"
04b606f @mkristian moved gwt and jetty-run to new gems
authored
24 s.executables = ['rmvn']
0f282c2 @mkristian first import
authored
25 s.homepage = %q{http://github.com/mkristian/ruby-maven}
73093a9 @mkristian polishing up. added gwt command
authored
26 s.rdoc_options = ["--main", "README.md"]
27 s.require_paths = ['lib/ruby']
0f282c2 @mkristian first import
authored
28 s.rubygems_version = %q{1.3.5}
73093a9 @mkristian polishing up. added gwt command
authored
29 s.summary = %q{maven support for ruby projects with gemspec, Gemfile}
62def8d @mkristian added specs and basic test for execution of maven
authored
30 s.add_dependency 'thor', '>= 0.14.6', '< 2.0' # mimic rails
72386bc @mkristian prepare release
authored
31 s.add_dependency 'maven-tools', "~> 0.32"
98919a0 @mkristian * more lenient version constraint for maven-tools
authored
32 s.add_development_dependency 'minitest', '~> 4.3'
72386bc @mkristian prepare release
authored
33 s.add_development_dependency 'rake', '~> 10.0.3'
0f282c2 @mkristian first import
authored
34
0c965f6 @mkristian updated readme
authored
35 File.chmod(0755, File.join("bin", "mvn"))
0f282c2 @mkristian first import
authored
36 end
37
Something went wrong with that request. Please try again.