'lein javac' results in java.lang.NoSuchMethodError: org.apache.tools.ant.launch.Locator.fromJarURI #14

Closed
davidrupp opened this Issue Dec 11, 2011 · 1 comment

Projects

None yet

1 participant

@davidrupp
Contributor

The dev dependency [org.clojars.mmcgrana/lein-javac "1.2.1"] brings in ant-launcher-1.6.5.jar, whose version of Locator does not include the fromJarURI() method. It looks like modern lein (Leiningen 1.6.2 on Java 1.6.0_26 Java HotSpot(TM) 64-Bit Server VM for me) has a built-in javac task that wants a more modern ant-launcher. I was able to 'lein javac && lein test' without a problem after removing everything from lib/, removing the dev dependency, and running 'lein deps'.

@davidrupp
Contributor

This is resolved with commit #f2bb20b8.

@davidrupp davidrupp closed this Jan 28, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment