TextMate Support for XML Schema (XSD)
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
Commands
Snippets
Support
Syntaxes
README.md
info.plist

README.md

TextMate Bundle for XML Schema Development (XSD)

To install with Git:

mkdir -p ~/Library/Application\ Support/TextMate/Bundles
cd ~/Library/Application\ Support/TextMate/Bundles
git clone git@github.com:mmorga/XSD.tmbundle.git "XSD.tmbundle"
osascript -e 'tell app "TextMate" to reload bundles'

Prereqs

  • Ruby 1.8.7 or greater is required.
  • xmllint is used for validation against the XML Schema Schema.

What does it do?

  • Provides a number of snippets for easier completion.
  • Provides validation via xmllint ctrl-shift-V
  • Provides element help links to the w3.org XML Schema 1.1 documentation ctrl-H

Mark Morga markmorga@gmail.com