Permalink
Commits on Sep 13, 2010
  1. README installation instructions simlified and clarified to specific …

    …that Bundler is required, even under Rails 2
    justinfrench committed Sep 13, 2010
Commits on Sep 10, 2010
  1. resolves GH-365 by adding top and bottom padding to the li, then taki…

    …ng it away with a negative margin (top) and reduced margin (bottom)
    justinfrench committed Sep 10, 2010
Commits on Sep 8, 2010
  1. Merge remote branch 'origin/rails3'

    This commit moves the main development branch back to master since
    a rails 2.3.x and rails 3.0.x compatible version has been published.
    
    The current rails3 branch will be deprecated shortly.
    mjonuschat committed with mjonuschat Sep 8, 2010
  2. new gemspec

    justinfrench committed Sep 8, 2010
  3. version bump

    justinfrench committed Sep 8, 2010
  4. changelog catch-up

    justinfrench committed Sep 8, 2010
Commits on Sep 2, 2010
Commits on Sep 1, 2010
  1. Ignore .rvmrc file

    sobrinho committed Sep 1, 2010
Commits on Aug 31, 2010
Commits on Aug 30, 2010
  1. ignore .rvmrc

    justinfrench committed Aug 30, 2010
  2. changelog catch-up

    justinfrench committed Aug 30, 2010
Commits on Aug 28, 2010
  1. new gemspec

    justinfrench committed Aug 28, 2010
  2. version bump to 1.1.0.beta

    justinfrench committed Aug 28, 2010
Commits on Aug 23, 2010
  1. Merge branch 'rails3' into rails3-nested-options

    Conflicts:
    	lib/formtastic.rb
    sobrinho committed Aug 23, 2010
  2. Sync with 1.0.1 release - Merge remote branch '1.0-stable' into rails3

    Conflicts:
    	CHANGELOG
    	rails/init.rb
    mjonuschat committed Aug 23, 2010
Commits on Aug 21, 2010
  1. CHANGELOG update

    justinfrench committed Aug 21, 2010
  2. new gemspec

    justinfrench committed Aug 21, 2010
  3. Version bump to 1.0.1

    justinfrench committed Aug 21, 2010
  4. Simplified the require statements in rails/init.rb to avoid "already …

    …initialized constant" warnings.
    
    I think Rails loads the init before lib/formtastic.rb (which requires lib/formtastic.rb). When the Rails process later loads lib/formtastic.rb, the warnings happen. For some reason, simplifying these requires has avoided the warnings. Tested under Rails 2.3.8.
    justinfrench committed Aug 16, 2010
Commits on Aug 16, 2010
  1. Simplified the require statements in rails/init.rb to avoid "already …

    …initialized constant" warnings.
    
    I think Rails loads the init before lib/formtastic.rb (which requires lib/formtastic.rb). When the Rails process later loads lib/formtastic.rb, the warnings happen. For some reason, simplifying these requires has avoided the warnings. Tested under Rails 2.3.8.
    justinfrench committed Aug 16, 2010
Commits on Aug 12, 2010
Commits on Aug 11, 2010
  1. CHANGELOG catch-up

    justinfrench committed Aug 11, 2010
  2. prep README for 1.0

    justinfrench committed Aug 11, 2010
Commits on Aug 10, 2010
Commits on Aug 9, 2010
  1. Changed CSS to work better with HTML4/5:

    * changed styles to clear containing floats on fieldsets and list items with a more modern clearing technique that doesn't rely on XHTML attributes on the HTML tag
    * removed a double declaration that's no longer required now that the xmlns rules are removed
    
    Checked in IE7/8, FF3.6 & Safari 5. The overflow technique should work in pretty much everything except IE6. Add zoom:1; for IE6 support.
    justinfrench committed Aug 9, 2010
  2. new gemspec

    justinfrench committed Aug 9, 2010