Skip to content

Comparing changes

Choose two branches to see what’s changed or to start a new pull request. If you need to, you can also compare across forks.

Open a pull request

Create a new pull request by comparing changes across two branches. If you need to, you can also compare across forks.
...
  • 19 commits
  • 7 files changed
  • 0 commit comments
  • 2 contributors
Showing with 15 additions and 24 deletions.
  1. +1 −1 .document
  2. +2 −0 .gitignore
  3. +3 −1 License.txt
  4. +3 −3 README.markdown → README.md
  5. +0 −14 Rakefile
  6. +1 −1 lib/rspec/version.rb
  7. +5 −4 rspec.gemspec
View
2 .document
@@ -1,2 +1,2 @@
-README.markdown
+README.md
License.txt
View
2 .gitignore
@@ -5,3 +5,5 @@ doc
pkg
Gemfile.lock
.bundle
+*.rbc
+bin
View
4 License.txt
@@ -1,6 +1,8 @@
(The MIT License)
-Copyright (c) 2009, 2010 David Chelimsky, Chad Humphries
+Copyright (c) 2009 Chad Humphries, David Chelimsky
+Copyright (c) 2006 David Chelimsky, The RSpec Development Team
+Copyright (c) 2005 Steven Baker
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
6 README.markdown → README.md
@@ -20,17 +20,17 @@ components of rspec that you're not using.
### rspec-core
* [Cucumber features](http://relishapp.com/rspec/rspec-core)
-* [RDoc](http://rubydoc.info/gems/rspec-core/2.4.0/frames)
+* [RDoc](http://rubydoc.info/gems/rspec-core/frames)
### rspec-expectations
* [Cucumber features](http://relishapp.com/rspec/rspec-expectations)
-* [RDoc](http://rubydoc.info/gems/rspec-expectations/2.4.0/frames)
+* [RDoc](http://rubydoc.info/gems/rspec-expectations/frames)
### rspec-mocks
* [Cucumber features](http://relishapp.com/rspec/rspec-mocks)
-* [RDoc](http://rubydoc.info/gems/rspec-mocks/2.4.0/frames)
+* [RDoc](http://rubydoc.info/gems/rspec-mocks/frames)
## Install
View
14 Rakefile
@@ -2,20 +2,6 @@ require "bundler"
Bundler.setup
Bundler::GemHelper.install_tasks
-task :build => :raise_if_psych_is_defined
-
-task :raise_if_psych_is_defined do
- if defined?(Psych)
- raise <<-MSG
-===============================================================================
-Gems compiled in Ruby environments with Psych loaded are incompatible with Ruby
-environments that don't have Psych loaded. Try building this gem in Ruby 1.8.7
-instead.
-===============================================================================
-MSG
- end
-end
-
require 'rake'
require 'fileutils'
require 'pathname'
View
2 lib/rspec/version.rb
@@ -1,5 +1,5 @@
module RSpec # :nodoc:
module Version # :nodoc:
- STRING = '2.6.0'
+ STRING = '2.11.0'
end
end
View
9 rspec.gemspec
@@ -7,19 +7,20 @@ Gem::Specification.new do |s|
s.name = "rspec"
s.version = RSpec::Version::STRING
s.platform = Gem::Platform::RUBY
+ s.license = "MIT"
s.authors = ["Steven Baker", "David Chelimsky"]
- s.email = "rspec-users@rubyforge.org;"
+ s.email = "rspec-users@rubyforge.org"
s.homepage = "http://github.com/rspec"
s.summary = "rspec-#{RSpec::Version::STRING}"
s.description = "BDD for Ruby"
- s.rubygems_version = "1.3.7"
s.rubyforge_project = "rspec"
- s.files = `git ls-files`.split("\n")
+ s.files = `git ls-files -- lib/*`.split("\n")
+ s.files += ["License.txt"]
s.test_files = `git ls-files -- {spec,features}/*`.split("\n")
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
- s.extra_rdoc_files = [ "README.markdown" ]
+ s.extra_rdoc_files = [ "README.md" ]
s.rdoc_options = ["--charset=UTF-8"]
s.require_path = "lib"

No commit comments for this range

Something went wrong with that request. Please try again.