Skip to content
Example code showing how to install dependent gems based on a user's installed ruby
Ruby
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
gem_dep_example
gem_dep_polish
gem_dep_shine
LICENSE.txt
README.markdown

README.markdown

gem_dependency_example

An example gem that shows how to use the gem extension framework to install gems on the user's system based on the Ruby version the user has installed.

The gem_dep_example folder has the example with the proper layout and annotated code.

The other folders are the gems that will be loaded by gem_dep_example, the choice of which depends if the user has Ruby 1.9 installed or not.

The code is based on the example found in the Ruby Programming/Ruby Gems wiki book. http://en.wikibooks.org/wiki/Ruby_Programming/RubyGems

License

Licensed under the MIT license (see LICENSE.txt)

You can’t perform that action at this time.