Skip to content

GeoIP.h file not found #43

Closed
sabernar opened this Issue Dec 12, 2012 · 2 comments

3 participants

@sabernar

[ws v0.4.24] Attempting to compile blazing fast native extensions.
CXX(target) Release/obj.target/geoip/src/global.o
CXX(target) Release/obj.target/geoip/src/init.o
In file included from ../src/init.cc:7:
In file included from ../src/netspeed.h:12:
../src/node_geoip.h:7:10: fatal error: 'GeoIP.h' file not found
#include
^
1 error generated.
make: *** [Release/obj.target/geoip/src/init.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:236:23)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:99:17)
gyp ERR! stack at Process._handle.onexit (child_process.js:678:10)
gyp ERR! System Darwin 12.2.0
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /Users/shawnb/Documents/projects/hummingbird/node_modules/geoip
gyp ERR! node -v v0.8.14
gyp ERR! node-gyp -v v0.7.1
gyp ERR! not ok
npm ERR! geoip@0.4.6 install: node-gyp rebuild
npm ERR! sh "-c" "node-gyp rebuild" failed with 1
npm ERR!
npm ERR! Failed at the geoip@0.4.6 install script.
npm ERR! This is most likely a problem with the geoip package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls geoip
npm ERR! There is likely additional logging output above.

npm ERR! System Darwin 12.2.0
npm ERR! command "node" "/usr/local/bin/npm" "install"
npm ERR! cwd /Users/shawnb/Documents/projects/hummingbird
npm ERR! node -v v0.8.14
npm ERR! npm -v 1.1.65
npm ERR! code ELIFECYCLE
[ws v0.4.24] Native extension compilation successful!
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/shawnb/Documents/projects/hummingbird/npm-debug.log
npm ERR! not ok code 0

@ditesh
ditesh commented Dec 13, 2012

Install the development package. On Fedora, its GeoIP-devel:

yum install GeoIP-devel

@mnutt
Owner
mnutt commented Jan 19, 2013

Yes, unfortunately a GeoIP dependency is still required. I'm going to add that to the documentation. I'm hoping that eventually this will get merged into the geoip npm module, removing the need for external geoip:

kuno/GeoIP#27

@mnutt mnutt closed this Jan 19, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.