Permalink
Browse files

Update Debian packaging.

  * rules:  Workaround for missing dependency information in libmongoclient package
  * control: update build depends for all the variety of mongo dev packages
  * control: update runtime depends for all the variety of mongo runtime packages



git-svn-id: http://luamongo.googlecode.com/svn/trunk@65 17e306f6-9439-11de-a13a-71b910e68cc8
  • Loading branch information...
1 parent 700bb9c commit 4c90838e7525ade17dd7d5ccdbb39d748c4bb236 neomantra committed Jan 19, 2011
Showing with 15 additions and 2 deletions.
  1. +9 −0 debian/changelog
  2. +2 −2 debian/control
  3. +4 −0 debian/rules
View
@@ -1,3 +1,12 @@
+luamongo (0.4-1) unstable; urgency=low
+
+ * Sync to upstream SVN r64
+ * rules: Workaround for missing dependency information in libmongoclient package
+ * control: update build depends for all the variety of mongo dev packages
+ * control: update runtime depends for all the variety of mongo runtime packages
+
+ -- Evan Wies <neomantra@gmail.com> Tue, 18 Jan 2011 21:11:42 -0400
+
luamongo (0.1) unstable; urgency=low
* Initial Release.
View
@@ -2,12 +2,12 @@ Source: luamongo
Section: database
Priority: optional
Maintainer: Evan Wies <neomantra@gmail.com>
-Build-Depends: debhelper (>= 7), liblua5.1-0-dev, mongodb | mongodb-stable | mongodb-unstable | mongodb-snapshot
+Build-Depends: debhelper (>= 7), liblua5.1-0-dev, mongodb | mongodb-stable | mongodb-unstable | mongodb-snapshot | libmongoclient-dev | mongodb-dev
Standards-Version: 3.8.3
Homepage: http://code.google.com/p/luamongo/
Package: liblua5.1-mongo
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, lua5.1, mongodb | mongodb-stable | mongodb-unstable | mongodb-snapshot
+Depends: ${shlibs:Depends}, ${misc:Depends}, lua5.1, mongodb | mongodb-stable | mongodb-unstable | mongodb-snapshot | mongodb-clients | libmongoclient | libmongoclient1.6
Description: Lua driver for MongoDB
Lua (http://www.lua.org) driver for MongoDB (http://www.mongodb.org).
View
@@ -11,3 +11,7 @@
%:
dh $@
+
+# Workaround for missing dependency information in libmongoclient package
+override_dh_shlibdeps:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info

0 comments on commit 4c90838

Please sign in to comment.