Permalink
Browse files

๐Ÿ› Fix #62: Use published Plugin dependency

1 parent e3819f5 commit 1fbf09a456db1a84e9703f7db852ce7bf9320fb0 Marlow Payne committed Oct 3, 2016
Showing with 8 additions and 7 deletions.
  1. +3 โˆ’2 README.md
  2. +1 โˆ’1 examples/assets/js/config.js
  3. +1 โˆ’1 examples/norequire.html
  4. +2 โˆ’2 package.json
  5. +1 โˆ’1 tests/runner/sandbox-config.js
View
@@ -16,6 +16,7 @@ You can find a simple demo on [the Documentation page](http://mobify.github.io/b
* [jQuery](http://jquery.com/)
* [Velocity.js](http://julian.com/research/velocity/)
+* [Mobify's Plugin Factory](https://www.npmjs.com/package/mobify-plugin/)
### Zepto Support
@@ -39,7 +40,7 @@ To use with require.js, after installing through NPM you merely have to referenc
{
'paths': {
'$': 'node_modules/bellows-ui/node_modules/jquery/dist/jquery.min',
- 'plugin': 'node_modules/bellows-ui/node_modules/plugin/dist/plugin.min',
+ 'plugin': 'node_modules/bellows-ui/node_modules/mobify-plugin/dist/plugin.min',
'velocity': 'node_modules/bellows-ui/node_modules/velocity-animate/velocity'
'bellows': 'node_modules/bellows-ui/dist/bellows.min',
}
@@ -103,7 +104,7 @@ At a bare minimum, your markup structure should follow the above structure. You
<!-- Include dependencies -->
<script src="jqueryin.js"></script>
<script src="node_modules/velocity-animate/velocity.min.js"></script>
-<script src="node_modules/plugin/dist/plugin.min.js"></script>
+<script src="node_modules/mobify-plugin/dist/plugin.min.js"></script>
<!-- Include bellows.js -->
<script src="bellows.min.js"></script>
@@ -5,7 +5,7 @@ require.config({
'text': 'node_modules/text/text',
'$': 'node_modules/jquery/dist/jquery',
'velocity': 'node_modules/velocity-animate/velocity',
- 'plugin': 'node_modules/plugin/dist/plugin.min',
+ 'plugin': 'node_modules/mobify-plugin/dist/plugin.min',
'bellows': 'dist/bellows',
'setup-bellows': 'examples/assets/js/setup-bellows'
},
@@ -56,7 +56,7 @@
<p>Lorem honeyed locusts sit amet, none so wise, sed do eiusmod never resting ut labore et dolore magna aliqua. Manhood death before disgrace warrior, feed it to the goats spare me your false courtesy commodo consequat. Mace aute irure dolor in reprehenderit poison is a woman's weapon lord of light tower dwarf. The last of the dragons royal, godswood garron sister betrothed officia deserunt mollit anim id est snow.</p>
<script src="../node_modules/jquery/dist/jquery.js" ></script>
- <script src="../node_modules/plugin/dist/plugin.js" ></script>
+ <script src="../node_modules/mobify-plugin/dist/plugin.js" ></script>
<script src="../node_modules/velocity-animate/velocity.js"></script>
<script src="../src/js/bellows.js" ></script>
<script src="assets/js/setup-bellows.js"></script>
View
@@ -26,7 +26,6 @@
"mobify-code-style": "^2.4.2",
"mocha": "1.14.0",
"node-sass-import-once": "1.2.0",
- "plugin": "git+https://github.com/mobify/plugin.git#3.1.0",
"requirejs": "2.2.0",
"requirejs-glob": "git+https://github.com/mobify/requirejs-glob.git",
"text": "requirejs/text"
@@ -55,6 +54,7 @@
"author": "Mobify",
"dependencies": {
"jquery": "2.2.2",
- "velocity-animate": "1.2.3"
+ "velocity-animate": "1.2.3",
+ "mobify-plugin": "4.0.0"
}
}
@@ -7,7 +7,7 @@ require.config({
'velocity': 'node_modules/velocity-animate/velocity',
'chai': 'node_modules/chai/chai',
'mocha': 'node_modules/mocha/mocha',
- 'plugin': 'node_modules/plugin/dist/plugin',
+ 'plugin': 'node_modules/mobify-plugin/dist/plugin',
'bellows': 'dist/bellows'
},
'shim': {

0 comments on commit 1fbf09a

Please sign in to comment.