Random NPM Install Errors #28

Closed
jansepar opened this Issue Jul 10, 2012 · 1 comment

Comments

Projects
None yet
2 participants
Owner

jansepar commented Jul 10, 2012

From old repo:

@johnboxall :

Vincent ran into trouble installing mobify-js-tools because of some NPM whacki-ness.

For distribution, should we just include the modules we want in node_modules?

http://blog.nodejs.org/2012/02/27/managing-node-js-dependencies-with-shrinkwrap/
http://www.mikealrogers.com/posts/nodemodules-in-git.html

Vincent mentioned this helped: npm cache clean -g

@rrjamie :

There is some way to do this in npm... bundled dependencies, or something

rrjamie commented Jul 10, 2012

Depends what the error is. NPM seems to fuck up in weird ways (mostly probably to do with using sudo) and bundling stuff may not fix it.

jansepar closed this Apr 9, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment