Skip to content
This repository

scaffold project build command get an errors #50

Closed
vitvad opened this Issue April 01, 2013 · 4 comments

2 participants

Vitaly Shawn Jansepar
Vitaly

node --version
v0.10.2

npm --version
1.2.15

npm -g i mobify-client

5944 error Error: read ECONNRESET
5944 error     at errnoException (net.js:878:11)
5944 error     at TCP.onread (net.js:539:19)
5945 error If you need help, you may report this log at:
5945 error     <http://github.com/isaacs/npm/issues>
5945 error or email it to:
5945 error     <npm-@googlegroups.com>
5946 error System Windows_NT 6.1.7601
5947 error command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "-g" "install" "mobify-client"
5948 error cwd C:\Users\newbie
5949 error node -v v0.10.2
5950 error npm -v 1.2.15
5951 error syscall read
5952 error code ECONNRESET
5953 error errno ECONNRESET
5954 verbose exit [ 1, true ]

>mobify --version
0.3.19

OS: win7

mobify init test
cd test
mobify build

get such log:
```javascript
Starting Build in bld

path.js:116
        throw new TypeError('Arguments to path.resolve must be strings');
        ^
TypeError: Arguments to path.resolve must be strings
    at Object.exports.resolve (path.js:116:15)
    at Object.Fetcher.resolve (C:\Users\newbie\AppData\Roaming\npm\node_modules\mobify-client\lib\fetcher.js:2
1:21)
    at next (C:\Users\newbie\AppData\Roaming\npm\node_modules\mobify-client\lib\fetcher.js:37:33)
    at C:\Users\newbie\AppData\Roaming\npm\node_modules\mobify-client\lib\fetcher.js:46:28
    at fs.js:207:20
    at C:\Users\newbie\AppData\Roaming\npm\node_modules\mobify-client\node_modules\fstream\node_modules\gracef
ul-fs\graceful-fs.js:53:5
    at C:\Users\newbie\AppData\Roaming\npm\node_modules\mobify-client\node_modules\fstream\node_modules\gracef
ul-fs\graceful-fs.js:62:5
    at Object.oncomplete (fs.js:107:15)

can someone help with this?

Vitaly

solved - replace node.exe to v0.8.2 - http://nodejs.org/dist/v0.8.2/

Vitaly vitvad closed this April 02, 2013
Shawn Jansepar
Collaborator

Hi @vitvad , thanks for filing this issue! I'm going to reopen it mainly because reverting to 0.8.2 should not be the solution - 0.10.x should work fine.

Shawn Jansepar jansepar reopened this April 02, 2013
Vitaly

@jansepar, Ithink better open new ticket with a bug label
FYI:
http://nodejs.org/dist/v0.11.0/ - future node revision, has same issues as 0.10.x

Shawn Jansepar
Collaborator

@vitvad the issue is resolved, please update mobify-client!

Shawn Jansepar jansepar closed this April 09, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.