Boost >= 1.34 is required #154

mitchblank opened this Issue Apr 11, 2012 · 4 comments


None yet

4 participants


mosh seems to use the boost::typeof library which was added in 1.34. However, ./configure is happy to accept the boost 1.33.1 that came installed on CentOS 5.4

I recommend you change so instead of:

AX_BOOST_BASE(, , [AC_MSG_ERROR([Unable to find boost libraries.])]) do

AX_BOOST_BASE(1.34, , [AC_MSG_ERROR([Unable to find boost libraries.])])

configure will then print an informational message if the minimum version isn't met


Just to verify this, I did a build against boost 1.34 and it worked fine. It definitely seems to be the minimum version required


I'm working on eliminating the Boost dependency entirely.

rurban commented Apr 12, 2012

Better idea, thanks! (get rid of BOOST_AUTO)


As of 937882c we've removed the Boost dependency. This will be in the next release.

@keithw keithw closed this Apr 16, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment