Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Tree: b405ea11e3
Fetching contributors…

Cannot retrieve contributors at this time

52 lines (45 sloc) 1.162 kB
.breadcrumbs
%a{ :href => "/" }
Documentation
 > 
%a{ :href => "/packages/" }
Libraries
 > 
%a{ :href => "/packages/autoconf/" }
Autoconf
%hr
%h2
Quick fix
%p
Remove all the manually installed packages:
= sh_cmd "rm -rf $rvm_path/usr"
Find the requirements (follow the instructions):
= sh_cmd "rvm requirements"
Reinstall ruby:
= sh_cmd "rvm reinstall 1.9.3"
%h2
Autoconf
%p
If your ruby (usually 1.9.2-head / trunk) fails to compile and the make error log shows
that you do not have a current enough version of autoconf ::cough:: CentOS ::cough:: then
you can install it into your RVM.
%pre.code
:preserve
$ rvm pkg install autoconf
%p
Note that autoconf will be installed to ~/.rvm/bin so be sure it is in your path.
%p
If it is not in your path you can add it like this
%pre.code
:preserve
$ export PATH=$rvm_path/bin:$PATH
%p
Once autoconf has been installed, you can then (re) install your ruby
%pre.code
:preserve
$ rvm reinstall 1.9.2-head
%p
In case of compilation problems try:
%pre.code
:preserve
$ rvm --skip-autoreconf pkg install autoconf
Jump to Line
Something went wrong with that request. Please try again.