New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fail to spawn container: bad file descriptor #3485

Closed
Soulou opened this Issue Jan 7, 2014 · 7 comments

Comments

Projects
None yet
3 participants
@Soulou
Contributor

Soulou commented Jan 7, 2014

The server is using ubuntu 12.04 64 bits completely updated and devicemapper as a storage driver for docker.

Client version: 0.7.3
Go version (client): go1.2
Git commit (client): 8502ad4
Server version: 0.7.3
Git commit (server): 8502ad4
Go version (server): go1.2
Last stable version: 0.7.3
root@ubuntu:~# docker run -i -t ubuntu:quantal bash
lxc-start: failed to spawn 'bf7240628e2fb2efd231c021026bd10d7cdfd67aeb61ba96f31dd3adf60108e0'
[error] commands.go:2458 Error getting size: bad file descriptor

#2683

In this case, the error is not exactly the same:

[error] commands.go:2044 Error resize: Error: bad file descriptor

#3387

In this bug lxc-start is giving much more error than in my case.

@Soulou

This comment has been minimized.

Show comment
Hide comment
@Soulou

Soulou Jan 7, 2014

Contributor

The Error getting error is linked to the TTY

root@ubuntu:~# docker run -i buntu:quantal bash
lxc-start: failed to spawn '094311954bb645646d150232892bc1d3a2d9b931e621f651f0ef85148db2228c'

The problem persists even without, without any specific error.

Contributor

Soulou commented Jan 7, 2014

The Error getting error is linked to the TTY

root@ubuntu:~# docker run -i buntu:quantal bash
lxc-start: failed to spawn '094311954bb645646d150232892bc1d3a2d9b931e621f651f0ef85148db2228c'

The problem persists even without, without any specific error.

@Soulou

This comment has been minimized.

Show comment
Hide comment
@Soulou

Soulou Jan 7, 2014

Contributor

With dmesg I have:

[ 2723.960211] EXT4-fs (dm-374): mounted filesystem with ordered data mode. Opts: discard
[ 2724.321374] EXT4-fs (dm-375): mounted filesystem with ordered data mode. Opts: discard
[ 2724.430885] device vethwtCKr2 entered promiscuous mode
[ 2724.430928] IPv6: ADDRCONF(NETDEV_UP): vethwtCKr2: link is not ready
Contributor

Soulou commented Jan 7, 2014

With dmesg I have:

[ 2723.960211] EXT4-fs (dm-374): mounted filesystem with ordered data mode. Opts: discard
[ 2724.321374] EXT4-fs (dm-375): mounted filesystem with ordered data mode. Opts: discard
[ 2724.430885] device vethwtCKr2 entered promiscuous mode
[ 2724.430928] IPv6: ADDRCONF(NETDEV_UP): vethwtCKr2: link is not ready
@Soulou

This comment has been minimized.

Show comment
Hide comment
@Soulou

Soulou Jan 7, 2014

Contributor

I've stopped docker, reboot, then move /var/lib/docker, switched to AUFS, same error with new docker directory.

Contributor

Soulou commented Jan 7, 2014

I've stopped docker, reboot, then move /var/lib/docker, switched to AUFS, same error with new docker directory.

@crosbymichael

This comment has been minimized.

Show comment
Hide comment
@crosbymichael

crosbymichael Jan 7, 2014

Contributor

What is your lxc version?

Contributor

crosbymichael commented Jan 7, 2014

What is your lxc version?

@Soulou

This comment has been minimized.

Show comment
Hide comment
@Soulou

Soulou Jan 7, 2014

Contributor
# lxc-version 
lxc version: 0.7.5

Version from the repository 0.7.5-3ubuntu69

Contributor

Soulou commented Jan 7, 2014

# lxc-version 
lxc version: 0.7.5

Version from the repository 0.7.5-3ubuntu69

@Soulou

This comment has been minimized.

Show comment
Hide comment
@Soulou

Soulou Jan 7, 2014

Contributor

Ok the bug is linked to cgroup-lite. The bug has been reported and has been corrected, waiting for mirror propagation.

https://bugs.launchpad.net/ubuntu/+source/cgroup-lite/+bug/1266815

Contributor

Soulou commented Jan 7, 2014

Ok the bug is linked to cgroup-lite. The bug has been reported and has been corrected, waiting for mirror propagation.

https://bugs.launchpad.net/ubuntu/+source/cgroup-lite/+bug/1266815

@steakknife

This comment has been minimized.

Show comment
Hide comment
@steakknife

steakknife Feb 19, 2014

Contributor

This might help: sudo apt-get install cgroup-lite if not already done so.

Contributor

steakknife commented Feb 19, 2014

This might help: sudo apt-get install cgroup-lite if not already done so.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment