Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ESM: remove code for Node versions <10 #4736

Merged
merged 1 commit into from Sep 4, 2021
Merged

ESM: remove code for Node versions <10 #4736

merged 1 commit into from Sep 4, 2021

Conversation

juergba
Copy link
Member

@juergba juergba commented Aug 29, 2021

Description

  • remove ESM code which adressed Node versions <10
  • move lib/esm-utils.js to lib/nodejs/esm-utils.js

@juergba juergba self-assigned this Aug 29, 2021
@juergba juergba added chore node.js semver-patch labels Aug 29, 2021
@juergba juergba requested a review from Aug 29, 2021
nicojs
nicojs approved these changes Aug 30, 2021
Copy link
Contributor

@nicojs nicojs left a comment

So I guess this means a new major version?

@juergba
Copy link
Member Author

@juergba juergba commented Aug 30, 2021

@nicojs no, semver-patch.

We already have dropped Node v8 support with Mocha v8 more than 14 months ago.
Currently Mocha supports Node >=v12, and inofficially it still runs with Node v10.
So this PR just removes old code debris.

lib/esm-utils.js and lib/utils/supportsEsModules() are not part of a public API.

@juergba juergba merged commit 97b8470 into master Sep 4, 2021
23 checks passed
@juergba juergba deleted the juergba/esm-debris branch Sep 4, 2021
@juergba juergba added this to the next milestone Sep 4, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
chore node.js semver-patch
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants