Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dependency updates, JDK17 #829

Merged
merged 20 commits into from Jul 27, 2022
Merged

Conversation

hduerkop
Copy link
Contributor

No description provided.

Copy link
Collaborator

@Raibaz Raibaz left a comment

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Thanks a lot for sending this through! I just have a concern about backwards compatibility up to 1.4.*.

@@ -11,13 +11,8 @@ jobs:
strategy:
matrix:
java-version: [11, 12, 13, 14, 15, 16, 17]
kotlin-version: [1.4.32, 1.5.31, 1.6.0]
kotlin-version: [1.6.21, 1.7.0-RC]
Copy link
Collaborator

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I'd keep a 1.4.* and a 1.5.* here.

jvmTarget = "1.8"
apiVersion = "1.4"
languageVersion = "1.4"
jvmTarget = "17"
Copy link
Collaborator

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Not sure about these: there have been issues about 1.4.* compatibilty in the past, meaning that some folks are still using MockK with Kotlin 1.4.*, so I'd like it to be backwards-compatible at least up to these versions.

@Raibaz
Copy link
Collaborator

Raibaz commented May 26, 2022

Looks like the versionName property is not available in the android gradle file:

/home/runner/work/mockk/mockk/mockk/android/build.gradle.kts:32:9: Unresolved reference: versionName

Can you PTAL?

Thanks!

@Raibaz
Copy link
Collaborator

Raibaz commented May 30, 2022

All gradle builds fail with

Caused by: java.lang.IllegalArgumentException: error: invalid source release: 17

I'm guessing either gradle needs to be upgraded, or JDK 17 is not supported yet.

@SilenLoc
Copy link

SilenLoc commented Jul 5, 2022

All gradle builds fail with

Caused by: java.lang.IllegalArgumentException: error: invalid source release: 17

I'm guessing either gradle needs to be upgraded, or JDK 17 is not supported yet.

See: https://docs.gradle.org/current/userguide/compatibility.html

@Raibaz
Copy link
Collaborator

Raibaz commented Jul 13, 2022

Can you please make sure this builds with earlier JDK versions and not just with 17?

Thanks

@Raibaz Raibaz merged commit 5026089 into mockk:master Jul 27, 2022
4 of 30 checks passed
kodiakhq bot pushed a commit to RBusarow/Dispatch that referenced this pull request Aug 23, 2022
[![Mend Renovate](https://app.renovatebot.com/images/banner.svg)](https://renovatebot.com)

This PR contains the following updates:

| Package | Change | Age | Adoption | Passing | Confidence |
|---|---|---|---|---|---|
| [io.mockk:mockk](https://mockk.io) ([source](https://togithub.com/mockk/mockk)) | `1.12.5` -> `1.12.7` | [![age](https://badges.renovateapi.com/packages/maven/io.mockk:mockk/1.12.7/age-slim)](https://docs.renovatebot.com/merge-confidence/) | [![adoption](https://badges.renovateapi.com/packages/maven/io.mockk:mockk/1.12.7/adoption-slim)](https://docs.renovatebot.com/merge-confidence/) | [![passing](https://badges.renovateapi.com/packages/maven/io.mockk:mockk/1.12.7/compatibility-slim/1.12.5)](https://docs.renovatebot.com/merge-confidence/) | [![confidence](https://badges.renovateapi.com/packages/maven/io.mockk:mockk/1.12.7/confidence-slim/1.12.5)](https://docs.renovatebot.com/merge-confidence/) |

---

### Release Notes

<details>
<summary>mockk/mockk</summary>

### [`v1.12.7`](https://togithub.com/mockk/mockk/releases/tag/1.12.7)

[Compare Source](https://togithub.com/mockk/mockk/compare/1.12.6...1.12.7)

#### What's Changed

-   Update android-sdk-detector.settings.gradle.kts by [@&#8203;aSemy](https://togithub.com/aSemy) in [mockk/mockk#886
-   only sign if the signing properties are present by [@&#8203;aSemy](https://togithub.com/aSemy) in [mockk/mockk#885
-   Fix an issue that Android libraries was not published by [@&#8203;kubode](https://togithub.com/kubode) in [mockk/mockk#887

#### New Contributors

-   [@&#8203;kubode](https://togithub.com/kubode) made their first contribution in [mockk/mockk#887

**Full Changelog**: mockk/mockk@1.12.6...1.12.7

### [`v1.12.6`](https://togithub.com/mockk/mockk/releases/tag/1.12.6)

[Compare Source](https://togithub.com/mockk/mockk/compare/1.12.5...1.12.6)

#### What's Changed

-   Dependency updates, JDK17 v2 by [@&#8203;aSemy](https://togithub.com/aSemy) in [mockk/mockk#863
-   Dependency updates, JDK17 by [@&#8203;hduerkop](https://togithub.com/hduerkop) in [mockk/mockk#829
-   Fix unmockkAll to work if constructor was mocked multiple times by [@&#8203;Chrostoq](https://togithub.com/Chrostoq) in [mockk/mockk#870
-   fix: fix value class field determination by [@&#8203;qoomon](https://togithub.com/qoomon) in [mockk/mockk#872
-   [#&#8203;854](https://togithub.com/mockk/mockk/issues/854) update projects to use new Kotlin Multiplatform Gradle plugin by [@&#8203;aSemy](https://togithub.com/aSemy) in [mockk/mockk#855

#### New Contributors

-   [@&#8203;hduerkop](https://togithub.com/hduerkop) made their first contribution in [mockk/mockk#829
-   [@&#8203;Chrostoq](https://togithub.com/Chrostoq) made their first contribution in [mockk/mockk#870

**Full Changelog**: mockk/mockk@1.12.5...1.12.6

</details>

---

### Configuration

📅 **Schedule**: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

🚦 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.

 **Rebasing**: Never, or you tick the rebase/retry checkbox.

🔕 **Ignore**: Close this PR and you won't be reminded about this update again.

---

 - [ ] If you want to rebase/retry this PR, click this checkbox.

---

This PR has been generated by [Mend Renovate](https://www.mend.io/free-developer-tools/renovate/). View repository job log [here](https://app.renovatebot.com/dashboard#github/RBusarow/Dispatch).



PR-URL: #564
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants