Skip to content
Permalink
Browse files

Bump requirements versions

Each package version is updated to use the last one if it doesn't
require code changes. Only Django REST Framework is currently stuck on
release 3.7 since breaking changes and deprecations come with newer
releases.
  • Loading branch information
jeromelebleu committed Jan 1, 2020
1 parent 4c4c08d commit d06692e06a197251e8e99e1e79578a8b79ad0027
Showing with 12 additions and 15 deletions.
  1. +1 −1 mysql-requirements.txt
  2. +9 −11 requirements.txt
  3. +2 −3 test-requirements.txt
@@ -1 +1 @@
mysqlclient<=1.3.99
mysqlclient<=1.4.99
@@ -1,24 +1,23 @@
django>=1.11.8,<=1.11.99
django-braces==1.11.0
django-ckeditor==5.2.2
django-reversion==2.0.12
django-braces==1.14.0
django-ckeditor==5.8.0
django-reversion==3.0.5
django-subcommand2==0.1.1
django-xforwardedfor-middleware==2.0

dj-database-url

coreapi==2.3.3
coreapi-cli==1.0.6
djangorestframework==3.7.3
coreapi-cli==1.0.9
djangorestframework==3.7.7

# bcrypt requires libffi-dev
bcrypt==3.1.4
dnspython==1.15.0
passlib==1.7.2
bcrypt # Requires libffi-dev and python-dev

dnspython==1.16.0
feedparser==5.2.1
gevent==1.4.0
ipaddress; python_version < '3.3'
jsonfield==2.0.2
passlib==1.7.1
Pillow # Optional dependency for django-ckeditor
progressbar33==2.4
py-dateutil==2.2
@@ -27,5 +26,4 @@ pytz
requests
rfc6266
lxml
backports.csv; python_version < '3'
chardet
@@ -1,6 +1,5 @@
argon2-cffi>=16.1.0
factory-boy>=2.4
mock==2.0.0; python_version < '3.3'
httmock==1.2.5
testfixtures==4.7.0
httmock==1.3.0
testfixtures==6.10.3
tox

0 comments on commit d06692e

Please sign in to comment.
You can’t perform that action at this time.