New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update phpmailer to version 5.2.14 #12808

Merged
merged 2 commits into from Dec 7, 2015

Conversation

Projects
None yet
2 participants
@exside
Contributor

exside commented Dec 6, 2015

What does it do ?

Update the phpmailer class to version 5.2.14. Current version is only 5.2.13 so I hope/guess the possibility for breaking stuff is quite small, not sure though if it fixes the warning given by php7cc as mentioned in the issue below. Will check that once I have a "merged" php7 version with all related changes. Couldn't find the removed set_magic_quotes_runtime() method used anymore in the code though...

Why is it needed ?

Keeping libs up to date and fixing a security issue =). For details see https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.14

Related issue(s)/PR(s)

Maybe also #12797

exside added some commits Dec 6, 2015

@Mark-H Mark-H self-assigned this Dec 7, 2015

@Mark-H Mark-H merged commit a441131 into modxcms:2.x Dec 7, 2015

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@Mark-H Mark-H added this to the v2.5.0-pl milestone Dec 7, 2015

@Mark-H

This comment has been minimized.

Collaborator

Mark-H commented Dec 7, 2015

Thanks @exside!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment