Twitter gem has changed #2

Open
myobie opened this Issue Jun 4, 2009 · 1 comment

Comments

Projects
None yet
2 participants

myobie commented Jun 4, 2009

Instead of Twitter::Base.new(username, password) you have to build a Twitter::HTTPAuth.new('username', 'password') first. I am willing to submit a patch, but I am not sure if backward compatibility with the old twitter gem is necessary?

Owner

mojombo commented Aug 9, 2009

It would be best to maintain backwards compatibility for a while and add a deprecation notice to the documentation. Sometime down the road we can then remove support for the old gem.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment