Skip to content
Newer
Older
100644 47 lines (37 sloc) 1.38 KB
2fa2455 @mojombo Initial commit.
authored
1 Gem::Specification.new do |s|
2 s.specification_version = 2 if s.respond_to? :specification_version=
3 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
4 s.rubygems_version = '1.3.6'
5
ffca0ec @mojombo Update gemspec.
authored
6 s.name = 'omniship'
7 s.version = '0.0.1'
8 s.date = '2010-11-27'
9 s.rubyforge_project = 'omniship'
2fa2455 @mojombo Initial commit.
authored
10
11 s.summary = "OmniShip is a unified API for various shipping APIs."
12 s.description = "OmniShip is a unified API for various shipping APIs such as UPS, FedEx, and DHL."
13
14 s.authors = ["Tom Preston-Werner"]
15 s.email = 'tom@mojombo.com'
16 s.homepage = 'http://github.com/mojombo/omniship'
17
18 s.require_paths = %w[lib]
19
20 s.rdoc_options = ["--charset=UTF-8"]
21 s.extra_rdoc_files = %w[LICENSE README.md]
22
23 s.add_dependency('handsoap', [">= 1.1.7", "< 2.0.0"])
9eb027d @mojombo Add json dep.
authored
24 s.add_dependency('json', [">= 1.4.6", "< 2.0.0"])
2fa2455 @mojombo Initial commit.
authored
25
26 s.add_development_dependency('shoulda', [">= 2.11.3", "< 3.0.0"])
27
28 # = MANIFEST =
29 s.files = %w[
ffca0ec @mojombo Update gemspec.
authored
30 README.md
31 Rakefile
32 lib/omniship.rb
33 lib/omniship/ups.rb
34 lib/omniship/ups/track.rb
35 lib/omniship/ups/track/shipment.rb
36 lib/omniship/ups/track_request.rb
37 lib/omniship/ups/track_response.rb
38 omniship.gemspec
39 test/config.yml.example
40 test/helper.rb
41 test/test_ups_track.rb
2fa2455 @mojombo Initial commit.
authored
42 ]
43 # = MANIFEST =
44
45 s.test_files = s.files.select { |path| path =~ /^test\/test_.*\.rb/ }
46 end
Something went wrong with that request. Please try again.